Jump to content
  • 0

Role/Power Levelup bug


Maelwys

Question

After I completed the final scenario of Adv 3, I apparently messed up. And now my Valeros seems to be one power feat short of where he should be. First off, somebody please check my math and make sure I'm not missing somebody...

 

Valeros powers:

Hand size: 5 (1 power feat)

Profiencies: Light Armour, Heavy Armour, Weapons (all starting)

Teamwork: Greater Teamwork/1d4+2 (2 power feats)

Weapon Mastery (starting)

 

And that's it. So by my math, I'm missing one.

 

And now, here's what happened...

 

After I'd completed Adventure 3, I got to pick a Role and a Power Feat for each character. When I was looking at Valeros, I decided upon Shield Another (under the Guardian role) for my next power feat, and checked it off. Then I flipped over to take a quick look at the Weapon Master role to make sure I didn't prefer something there, before finalizing my choice. Content that I didn't see anything there that I liked better, I continued on selecting power feats for the rest of my party. Unfortunately, it seems that I never flipped back to the Guardian role on Valeros. However, when I'd selected everybody else it still let me proceed to the deckbuilding screen (because I'd selected both a Power Feat and a Role for Valeros, it apparently didn't check for a mismatch). But then because it thought I'd selected the Weapon Master role (it defaults back to that role every time I open up his character sheet), my power feat selection was deemed invalid and so didn't apply. (In hindsight I see that this was my fault, I was thinking that it determined which role I'd selected based on which Power feat I'd selected, not based on which tree I'd looked at most recently)

 

So now my Valeros is left short one power feat. I tried replaying the final scenario with the same party (hoping that maybe it would do the math, realize he didn't have enough feats, and give him an extra to catch up with the rest of the party) but that didn't help (because it has him flagged as completed on that one). So... any suggestions for how I can get Valeros caught up with the rest of the group?

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hmmm... Seems that you have now role card weapon Master and the power feat is From armour Master.

I can see no any way to fix this...

But the game should not allow you to take power From another role and then chose another role in anyway, so this is a bug.

Easily avoided, by not selecting power untill you select the role for sure, but a bug in anyway.

Edited by Hannibal_PJV
Link to comment
Share on other sites

  • 0

(In hindsight I see that this was my fault, I was thinking that it determined which role I'd selected based on which Power feat I'd selected, not based on which tree I'd looked at most recently)

I , for one, CANNOT see how this is your fault. It was the sensible assumption to made and the case you're describing is absurd.

You can still take a lesson from it - never *assume* anything interface-related in Pathfinder Adventures. I always try to go about the functions in the most 'literal' way possible and keep to a minimum the UI stressing, avoiding all weird combinations and action orders, if possible. I love the game, but it has a list of issues as long as my arm (like, literally, I'm keeping track of those) .

You can use the 'Mark Solved' button beneath a post that answers your topic or confirms it's not a bug.

The time that devs don't have to spend on the forum is a time they can spend on fixing the game.

Link to comment
Share on other sites

  • 0

Yes, this bug is still around.  I just encountered it on leveling up with Seoni, who is now a celestial sorcerer with the abyssal Worthy Sacrifice power.  Apparently whatever power you looked at last is selected, even if it is on the other role card.  I selected celestial, but didn't then examine any powers before leaving the level up screen.

 

Playing on an LG tablet, VER-573-20160815, PFID-D66A505853F8EEC6.

Would be nice if that character editor they mentioned could correct this....

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...