Jump to content
  • 0

Wrong difficulty for spell recharge



I just tried to recharge a Cure spell with Seelah at the beginning of the next character's turn (Lini in case it matters).


When I activated Crusade, the difficulty of the check jumped to 15 and I failed despite rolling a 9 (needing an 8). The check also indicated that the target was a Hill Giant rather than recharging Cure.


When my turn came around to Seelah again, there was a Hill Giant as the top card of the location deck she is at.

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

This troubles me every, single, game.  I understand bugs happen and it takes a while to work out kinks, but I have tried to get friends to play this game and they didn't have the physical card game experience I had so when something doesn't work instead of realizing it's not working right and working around it they just get confused and frustrated and give up on it.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...