Jump to content
  • 0

[3.0/WM2] Potions have various issues, worst of all sometimes freeze your character


thelee

Question

Potions and scrolls have long been finicky from 1.0, but I'm re-reporting this because I don't think this is getting attention (as evidenced by the fact that I keep running into these issue).

 

Some buggy scenarios:

 

Bug 1 [Annoying]: If my character gets interrupted while drinking a potion, sometimes they'll resume trying to drink the potion except when the animation completes the potion is not actually consumed (i.e. if I'm trying to drink one of 5 potions of power, even after the animation completes, I'll still have 5 potions of power left and no buff). Sometimes re-trying to drink the potion works.

 

Bug 2 [Severe]: Sometimes when my character drinks a potion, nothing will happen and my character will become permanently stuck (unable to move or take any action). Moreover, this character will prevent combat from ending. The only solution is to reload an earlier game.

 

Bug 3 [Annoying]: Sometimes if I tell my character to use a potion right as an action is completing, they will proceed to go through the animation of drinking the potion during recovery but then nothing will actually occur.

 

Bug 4 [bad]: Sometimes at the end of an action, I'll switch weapons (I have several characters with Fast Weapon Switch perk and one with that and Coil of Resourcefulness for 0second weapon switch delay, so switching weapons aggressively can be better than reloading a gun or waiting for recovery) and then immediately tell the character to quaff a potion. Sometimes when I do this, the potion will be queued up (visible in the "Current action" circle in the combat tooltip above their head), but the character will proceed to engage in auto-attack. This is most annoying with my wizard, who has a gun in one weapon slot and a quarterstaff in the other, and sometimes this means that I'll fire the gun, switch to quarterstaff to avoid reload, and drink an important potion (healing or a buff), but my wizard will instead just run straight into combat. The only recourse to this is to cancel the action (my keyboard hotkey is "X") which will remove the potion from the current action circle, and then try to drinkt the potion again.

 

Note: as hinted at in Bug #4, I aggressively use weapon switching in fights. I notice this causes occasional issues elsewhere, so I think there might be some bad interactions with potion usage and weapon switching. 

 

An of course, my main annoyance (not strictly a bug):

 

Potions and scrolls are incredibly finicky to try to use in actual combat, for two reasons:

 

1. The AI interacts very poorly with potion/scroll usage. If a character is in their cooldown (with the yellow bar above their heads) and I tell them to use a potion or scroll, sometimes their AI will make them completely forget that I ordered to do such a thing and auto-attack when their cooldown is finished. I can confirm this is the AI doing it because I've gotten into the habit of disabling the AI when I need to use a potion or scroll, and this has generally removed the issue. However, when I forget to do, there is a very high chance that the character will get distracted and attack instead.

 

2. It is very, very hard to use potions and scrolls in the midst of combat due to interrupts. The animation is stupidly slow (remember back in 1.0 when there was no animation? Those were the days). This would be less of an issue if Bug #1 from above didn't exist, but currently it means I have to babysit any character who wants to use a potion:

  a. character needs a potion?

  b. if yes, disable ai.

  c. select potion

  d. carefully watch animation. if they get interrupted, press X (to cancel any action in case bug #1 is about to occur) and try to drink potion again.

  e. carefully watch animation. wait to see them finish the drinking animation.

  f. double-check to see that they have gained the appropriate buff/healing. if not, start from step c all over again.

  g. re-enable ai.

  h. repeat for every character who needs to drink something through the course of the fight.

And god forbid I run into bug #2, especially at the tail end of a hard fight (I literally had this happen right after beating the white dragon in WM1... you don't quite know the frustration of having to repeat a hard fight because of a bug that happened because I told kana to drink a heal potion while killing a straggler ice blight).

 

and White March II/3.0 introduced a new annoyance:

3. I cannot actually see my potions until I hover my mouse over the little "quick item" icon on the toolbar. This is a major, major, major UX regression, especially since you have to hover your mouse and then carefully move your cursor UP and then RIGHT to get to the potions. God help you if you try to move diagonally UP-RIGHT, you'll lose the hover state and the quick item display disappears. This happens to me like 50% of the time I try to use an item, because my mouse usage is fairly rapid and imprecise (as I expect it would be for most users); the only solution is to slow way down my mouse usage every time I try to use an item. In web design, it's a fairly well-known trick to make the safe "hover zone" of a popup menu actually be a triangle from the initial button, so that users can move diagonally to the menu option that they want. The other part of this being bad UX is that I no longer have a good, visual reminder of my items (unless I explicitly hotkey them), so now it's a bit more skill intensive to remember that I have an obscure one-off potion on one of my characters.

 

Because the bugs above are not easy to reproduce, I don't have a definitive save game, but here's one with an output log wherein I ran into some of these potion issues during the game play; the save game is also near a fight, so you can try experimenting with potion usage: https://www.dropbox.com/sh/spsmxhhmimn4pjq/AAC0nAZ5-_ftLdZkirqB3uQVa?dl=0

Edited by thelee
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

The most annoying one is actually extremely easy to reproduce.

 

Step 1: Enter combat

Step 2: Attempt to quaff a potion

Step 3: Get interrupted while quaffing the potion

 

Expected result: Potion usage is delayed (consistent with other actions)

Actual result: Character decides to attack instead.

 

Toggling the AI seems to have little if any impact.

  • Like 1
Link to comment
Share on other sites

  • 0

Bumping this. Potions still need to be fixed. My game-version:V3.05.1186

 

Ever time I drink a heal potion, its because endurance is low and the its cross-fingers if that works or not. right now, I had to escape the game during combat because the potion didn't fire for two times. I',m playing in permadeath mode and it feels like cheating. But with broken heal potions what should i do?

 

OBSIDIAN, the potion-bug is a game-breaker and really need a fix.

Edited by Torin
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...