Jump to content
  • 0

Small framerate drops in certain areas.


Torm51

Question

So there are 3 very particular areas in the game that make my frame rate drop a bit.  It is noticeable but still very playable (which is better then a lot of people from what I read).  For me these are: Copperlane where the sand part is in the market, When I am outside around Durgan's Battery I drop to like 30 to 45 FPS and sometimes in Russetwood I get the same result.  Whenever I go inside in these areas like the Ice Cave or Galvinos the FPS is GREAT even in large fights with lots of effects.  At the end of the fight for St. Ydewn's Redeemer I did have a massive FPS tank for some reason.  It was when The Grey Sleeper procced a bunch of Vessels and my Wizard had the Wizards double spell going.  I am assuming with the already slower FPS in that area this made it tank.  It is the only time its happened to me in over 500 hours (I know...) of PoE.

 

Any advice? Is this just an optimization issue right now?  I have not updated my Drivers in a bit (like 6 months) but they just work REALLY well so I am hesitant to use other drivers lol..

 

I am currently at work so these are my specs from the top of my head.  I will post my DXdiag when I get home.

 

CPU : I7 (I know there are a lot of models but lets say I run games like DAI with zero frame rate drops)

 

12 gigs of Ram (DDR 3? its the fast type lol)

 

Nvidia GTX 770 (I know its not the best card in the market anymore)

 

I also have a solid state drive.

Edited by Torm51

Have gun will travel.

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Agreed.  I am on PoTD Trial of Iron so I literally have 3 saves.  My currently playthrough and 2 others.  I was thinking maybe updating my video drivers.  Just my current drivers work so well lol

Edited by Torm51

Have gun will travel.

Link to comment
Share on other sites

  • 0

I have the same issue as the OP, and it's definitely not drivers.  I have the latest.  The only areas I notice drops in Framerates are in the expansion areas, like white march.  Framerates start at 45- unlike the rest of the game which stay between 70 and 80.  Once combat starts, framerates drop to low 20's. 

 

Was hoping the patch 2.02 would fix this, but no luck.  It's been a month since release... any update/fix for this?  news?

Link to comment
Share on other sites

  • 0

I am having the same problems, but the framerate is even worse - during fight it dorps to like 10 fps. I have latest drivers installed and I have tried every step from framarate issues section here: https://forums.obsidian.net/topic/72049-workarounds-for-several-known-issues-4-07-15/. 

 

My computer specs:

Intel Core i% -4690K CPU @ 3.50 GHz

8.00 GB RAM

GeForce GTX 960

 

I don't belive it's a problem with my cpu - it is a powerfull machine. I have also attached a print screen of a program that was monitoring my cpu during the game - cpu utilization is very low considering such low framerate. I have no idea what can I do to fix it - now the game is almost unplayable.

 

post-157035-0-72244000-1443278219_thumb.png

Link to comment
Share on other sites

  • 0

I am having the same problems, but the framerate is even worse - during fight it dorps to like 10 fps. I have latest drivers installed and I have tried every step from framarate issues section here: https://forums.obsidian.net/topic/72049-workarounds-for-several-known-issues-4-07-15/. 

 

My computer specs:

Intel Core i% -4690K CPU @ 3.50 GHz

8.00 GB RAM

GeForce GTX 960

 

I don't belive it's a problem with my cpu - it is a powerfull machine. I have also attached a print screen of a program that was monitoring my cpu during the game - cpu utilization is very low considering such low framerate. I have no idea what can I do to fix it - now the game is almost unplayable.

 

 

Same here. Looks like UNITY version used in Pillars doesn't like certain Core I5 K - motherboard combination. Or maybe it's Core I5 K & GTX960 combo. Or maybe both.

Anyway, Termit only solution I found is to use "-force-d3d11" argument in command line (e.g. PillarsOfEternity.exe -force-d3d11). That should give You 30+ FPS but unfortunately breaks map.

Link to comment
Share on other sites

  • 0

Hello everyone,

 

Every computer may handle the game differently and we are constantly working on game optimization. So please bear with us while we work out the kinks. 

 

In the mean time try out these options and see if it improves performance. 

 

There may be various factors contributing to this issue, so take a look at the different fixes to try and solve the problem.

  • Disable Anti-Aliasing
    Many users have reported running into framerate issues and frequent crashing. If this is happening on your machine, go to the Graphics options and move the Graphics Quality slider to the left. This will disable anti-aliasing and should help your game's framerate.
     
  • Lower Resolution
    If framerate issues persist after disabling anti-aliasing, then lowering resolution can sometimes add significant increases to performance. This can sometimes help significantly, especially on machines with lower system specifications. We are working on more ways to support performance increases as we patch the client.
     
  • Clean and Clear Your Computer
    Dust and other particles can accumulate on parts of your computer, adversely affecting its efficiency when it attempts to run demanding programs and games. It is also important to make sure there is sufficient access to the ventilation fans for the computer so it can keep itself cool. Make sure to keep your computer or laptop clean and clear to avoid unnecessary strain and overheating.
     
  • Run as Administrator
    Some users are reporting major performance issues when not running the game as an administrator. If you are noticing issues such as this, please make sure that you are running the game in administrator mode. You can do this by doing the following:
  1. Navigate to the Pillars Of Eternity install folder.
  2. Right-Click on the executable icon.
  3. Choose Properties.
  4. On the Compatibility tab, select the Run This Program As An Administrator option.
  5. Click OK.
  6. If you see a User Account Control prompt, accept it.

 

Could you guys please post your systems specs (dxdiag file), save files, and an output log so I can add them to a bug report? 

 

Thank you for your support and patience!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...