Jump to content
  • 0

BUG: Doemenal Safe cannot be picked in edge case where it should be able to.


Zekram Bogg

Question

So, after I saved the Vailian merchant from the Doemenals and they started their war against me, and after having dealt with hit squads coming from them for a while I decided to return the favor and wipe out the Doemenals at their mansion.

 

I did so, killing everyone in Doemenal manor and then looted the place clean, except for the safe, due to this strange skill check requirement bug.

 

Basically, I have a Rogue-like Priest of Skaen in my party, who has a Mechanics level of six, currently (I think he's sixth level, as he's a bit behind the rest of my seventh level party since he was recruited after my actual rogue died to a trap - playing on Triple Crown mode - Path of the Damned, Expert Mode, and Trial of Iron). The Skill check on the Doemenal safe is for level 7 Mechanics, or level 6 but with 7 lockpicks.

 

I have 10 lockpicks currently possessed by my Rogue-like Priest, so this shouldn't be a problem, but whenever I try to pick the lock, it fails. I tried quitting and reloading in case it was some kind of weird issue on loading into that area that time, but upon reloading the problem persisted.

 

This seems to be a bug, as I've picked other level 7 locks with lockpicks prior to this action. I don't know if the bug is a mislabeling of the Safe's skill check (i.e. that it's actually a level 8 skill check labeled as 7), or that there's just something broken here. I was able to disable the trap on the safe already however (I think it was an arrow trap).

 

Steps to reproduce:

 

1. Create a character with Mechanics skill level 6 or get another character to Mechanics skill level 6.

2. Go to Doemenal Manor, and proceed to the 2nd floor (if hated by them, this may involve fighting).

3. On the second floor, to the east side of the manor, there is a safe, go into sneaking mode and disarm the trap on the safe.

4. Ensuring that you have more than seven lockpicks, but only a character with Mechanics level six, attempt to unlock the safe which is labeled as requiring 7 Mechanics Skill or 6 Mechanics skill and 7 Lockpicks.

5. Notice that despite meeting the 6 Mechanics Skill + 7 Lockpicks requirement, the lock refuses to open up.

 

Screenshots attached.

 

post-155443-0-26938600-1438379118_thumb.jpg

 

post-155443-0-40532200-1438379144_thumb.jpg

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hello, Zekram Bogg.  I am sorry for your inconvenience.  We are aware of this issue, as I tried to pick that chest a week or so ago.  It has been fixed internally and will show up fixed in the next patch.  Thank you for your support and patience during this issue.

- Refer to this thread if you are having trouble finding any information I requested http://forums.obsidi...eport-an-issue/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...