Jump to content
  • 0

Black Screen on New Game


Question

so i get into the game, noticed a few of the same things as other people (color blind on by default, it didn't save my button updates, etc). so the first time i got in, i was going with 1600x900 resolution. hit new game after looking over the options, and it plays the brief little intro thing where the view pans upwards... and then goes to a black screen. there is still audio as i can hear birds twittering and some music (which i'm assuming is the character creation screen), but i can't see anything, can't click on anything, nada. so i figured i'd try on a different resolution, same thing. tried in windowed mode, again the same thing. gotta say it's disappointing, but this is a beta so there be bugs and all that.

 

anyone else had this problem? i looked through 15 pages of posts, and didn't see anything similar to this.

Master Wetboy of the Obsidian Order of Eternity

Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

so i get into the game, noticed a few of the same things as other people (color blind on by default, it didn't save my button updates, etc). so the first time i got in, i was going with 1600x900 resolution. hit new game after looking over the options, and it plays the brief little intro thing where the view pans upwards... and then goes to a black screen. there is still audio as i can hear birds twittering and some music (which i'm assuming is the character creation screen), but i can't see anything, can't click on anything, nada. so i figured i'd try on a different resolution, same thing. tried in windowed mode, again the same thing. gotta say it's disappointing, but this is a beta so there be bugs and all that.

 

anyone else had this problem? i looked through 15 pages of posts, and didn't see anything similar to this.

Try hitting space when you get black screens like that. Sometimes the game doesn't unpause when loading areas / loading for the first time. Space, if that's the issue will "unpause" it and let you start.

 

Good luck :)

Edited by Azureblaze
Link to post
Share on other sites
  • 0

thanks for the tip on that. 

 

so... it loaded eventually. but there's so much lag with everything... like more than a minute to load a change between races, or from pressing a button, that it took me forever to even make a character. i was hoping it was just menu lag... but in game it's actually worse. so even though i got it loaded, it's completely unplayable for me until it comes out on mac or is optimized a lot more. it's so bad i can literally BARELY move the screen around. oh well. it looks pretty, and the little bit of the writing i've gotten to see is interesting as well.

Master Wetboy of the Obsidian Order of Eternity

Link to post
Share on other sites
  • 0

Are you using a laptop or an older computer? If it's a laptop, maybe try disabling your internal video card in the bios if you have two. You would have to find out if you have two though before you do that..maybe it's trying to use the weaker card if you have two is my thought.

 

With that said, the game is unomptimized at this point but they are working on the Mac and Linux beta releases too, so good luck man.

Link to post
Share on other sites
  • 0

it's a two year old toshiba with a single nvidia graphics card. i suspect it's just a lack of optimization more than anything else. i'll wait an update or two and see what happens. both my mac and the tosh are laptops, but the mac is far beefier (no option on that, was a school purchase, would vastly prefer having spent the money on a PC).

Master Wetboy of the Obsidian Order of Eternity

Link to post
Share on other sites
×
×
  • Create New...