Jump to content

Need OpenGL 1.4 Drivers?


Recommended Posts

KOTOR II won't work. When I open it and click game it comes up with a black screen and asks me to send an error report. From the hardware scan it seems I need the OpenGL 1.4 Driver(s). I updated my drivers for my NVIDIA 9600GT video card and installed OpenGL 3.0(32 bit should I have installed the 64 bit?) yet now it says I have OpenGL 1.1. I'm also running Windows XP and updated the game to 1.0b. Also when I installed the game it came up with an error but it was a movie so I just ignore it I doubt this could have anything to do with the game not working but I thought I'd mention it.

 

Oh and here's the full scan report thing.

 

[sWKotOR]

ReportDateTime=12/07/2009 10:09:39 AM

SysInfoVersion=v1.00.60

GameExists=1

GameVersion=v2.10.427

GameInstallLocation=C:\Program Files\LucasArts\SWKotOR2\

 

[OS]

Name=WinXP

Version=Windows XP v5.1 build 2600 Service Pack 2

Service Pack=Service Pack 2

Status=Pass

 

[swapFiles]

C:\pagefile.sys=768

 

[CPU]

CPUCount=1

CPUSpeed=2007

CPUFamily=15

CPUModel=15

CPUStepping=2

CPUVendor=AMD

CPUName=AMD Athlon 64 Processor 3200+

Status=Pass

 

[Memory]

RAM=512

Status=Pass

 

[Disk Free Space]

C: (NTFS), UNICODE=1.40GB

D: (FAT32), UNICODE=8.45GB

E: (NTFS), UNICODE=9.09GB

F: (FAT32), UNICODE=10.98GB

Status=Pass

 

[CD-ROMs]

DriveLetters=G:\,H:\

Drives=HL-DT-ST DVDRAM GSA-H12N

 

[Video]

Video Card Name=NVIDIA GeForce 9500 GT

Video Memory=512

Desktop Resolution=1024x768x32 @ 60Hz

DirectX=DirectX 9.0c (4.09.00.0904)

OpenGL Version=1.1.0

OpenGL Vendor=Microsoft Corporation

OpenGL Renderer=GDI Generic

NVidia Driver=6.14.11.8618

Vid Card Status=Warning

Vid Card Driver Status=Pass

GL Status=Fail

DX Status=Pass

 

[Audio]

Sound Card Name=Realtek AC'97 Audio

Status=Pass

 

 

;Game Options from swkotor2.ini

 

[Display Options]

FullScreen=1

Disable Movies=0

Disable Intro Movies=0

Sort Modules=1

Width=640

Height=480

BitsPerPixels=32

RefreshRate=60

 

[sound Options]

Number 3D Voices=23

Number 2D Voices=64

2D3D Bias=1.50

EAX=2

Sound Init=0

Disable Sound=0

Force Software=0

 

[Graphics Options]

EnableHardwareMouse=1

FullScreen=1

RefreshRate=60

Width=800

Height=600

Emitters=1

Anisotropy=1

Frame Buffer=1

Soft Shadows=0

Brightness=57

V-Sync=0

Texture Quality=2

Anti Aliasing=0

 

[Game Options]

Disable Movies=0

 

[config]

firstrun=0

Link to comment
Share on other sites

Indeed, OpenGL drivers are not separate from your video card drivers, they are part of it. Not to mention, the oldest drivers you can get for that particular card are already at least OpenGL 1.4 drivers. Looking at that output report, it is showing the current Nvidia driver version, but that driver should update the OpenGL drivers to 2.1.2. Additionally, any error during the installation of the game is a problem, regardless of the file it happened to be on when the error occurred.

 

The first thing I would do is a complete uninstall/delete leftover files/reinstall/update of the game and try it again. If that doesn't fix the issue, uninstall/reinstall your Nvidia drivers.

Cry 'Havoc' and let slip the dogs of War!

userbar2kq0.jpg

cogadh.jpeg

Link to comment
Share on other sites

Yeah I reinstalled the game and still got that error I'm gonna try another reinstall and I'll write down the specific file but I installed the game on my Dad's computer and it got the same file error yet the game has worked perfectly so far. Also I'll try reinstalling the drivers.

 

EDIT: I reinstalled the drivers to no success. The scan still says I have OpenGL 1.0.

Edited by Rakothurz
Link to comment
Share on other sites

There is a nice little utility for download here which can give you a "second opinion" on which OpenGL version you are running. Just to see if it is Kotor2 that scans your driver wrongly or if you have a Gfx card that indeed doesn't support OpenGL versions higher than 1.1.

“He who joyfully marches to music in rank and file has already earned my contempt. He has been given a large brain by mistake, since for him the spinal cord would surely suffice.” - Albert Einstein

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...