Jump to content
  • Sign Up
Sign in to follow this  
<SP

Savegame-editor

Recommended Posts

I`ve used the editor in kotor1 once and it made my game freeze up. It didnt even help to load from previous saves, everything went to hell.... :thumbsup: later i played the game through without the editor, but used cheats to see if that had anything to do with freezing up. It didnt.

 

Kotor2 had same problems. Tried to use editor twice and got tired of it. It just made a big mess of everything. Played it through without cheats and then with cheats--> no problems.

 

Why does the game go mad with the editor?? 1.0b patch is installed, maybe it doesnt work with that...or could some mods interfere with it??

Share this post


Link to post
Share on other sites

Are you refering to (KSE) v3.3.2, I use this editor all the time for both games but mostly TSL now it it works fine. One thing you should do just incase an error occurs is Back up your save games before editing them.

 

But what were you trying to edit in your save game?

Share this post


Link to post
Share on other sites

im using KSE v3.3.2, or was using... I edited my very first file on Peragus even before Kreia wakes up, so every save made since than has been affected. It didnt really matter backing up that file. It`s really frustrating to begin from nar shaddaa twice in a row.

 

I edited my pc`s stats, skills and feats. Sometimes items too, when i want to get some rare items. The general idea is that i modify my whole party towards a certain "style" for example: a sneaking party or all melee or all blasters..

 

Maybe you're trying to edit something that's outside the range of which the game allows?

what would that be?? please tell me! i downloaded the modmanager for kotor (maybe it`ll help avoid clashes that mess the game up.

Share this post


Link to post
Share on other sites

When you use the editor, make sure you close the game and not simply minimize your window. Also, save your changes in the editor beofe opening Kotor.

 

I never had such problems with the editor.

 

If this is not the problem, could you describe the changes you've made more precisely? Be careful if you play with classes.

Share this post


Link to post
Share on other sites

*force enlightment strikes* I`ve left the editor running in the background while playing the game! maybe that`s what creating the problems... never really thought about that. :) havent changed any classes, thanks to this forum<-- seen that a lot of problems come from changing classes.

Thanks for the tip, im gonna go play...i`ll report back

Share this post


Link to post
Share on other sites

well....I re-installed kotor2 and started a new game. Finished Peragus and going to Telos ---a new bug appears!!! (w00t) i hate this game! Im not using cheats or KSE and still this happens! WHY!! OH WHY!!!

 

Maybe because i have 25 mods/fixes running? Anyway. This happens when im finished with peragus and there is a cutscene with me+atton+kreia in the ****pit. Hyperdriving to Citadel Station. Talked to Kreia about her hand and the events in the galaxy. Then came back to the ****pit, talked to atton and then used the galaxy map to transport to Telos. It shows the movie clip when arriving to Citadel Station--> after that screen goes blank and it doesnt even start loading. And why is the word: "****pit" sensored.......

 

I feel really stupid posting only these "bug reports", but i dont know why this game is giving me such a hard time. Kotor1 worked fine with mods and so did kotor2, just recently it began to show signs of "erratical behaviour". Perhaps a memory wipe is needed :thumbsup: I thought re-installing the game would free me of the possible glithes done by KSE. I didnt even put "Enable Cheats....." in swkotor.ini.

Share this post


Link to post
Share on other sites
i hate this game! Im not using cheats or KSE and still this happens! WHY!! OH WHY!!!

youre_screwed.gif

 

If you have any further trouble that you are sure that you can attribute to KSE, however, please do the following:

 

make a file called kse.log in the same directory as KSE. Then make your edits with KSE and forward the .log file to me at the email address contained in the kse-readme.txt

Share this post


Link to post
Share on other sites

I've use KSE all the time an never ran into similar problems...

 

Now, If you say that you have 25_ mods installed...the problem could be there. Probably an incompatibility or a mod that is wrong.

 

Can you give a precise list of mods you are using? (with DL links if possible).

 

If have any .utc files in your override folder, could you name them? (some modders are sometimes afraid of scripting and chose editing .utc files instead: it's easier but if you happen to edit a non unique file or a unique file with a non unique tag, it can lead to problems. Note that sometimes editing .utc files is fine too. ).

 

Of course, there is a last possibility: that this is simply a bug not caused by mods

Share this post


Link to post
Share on other sites

These are from the Kotor2 Restoration Project site:

-Dxun puzzle fix

-Jedi Master fix on Dantooine

-Handmaiden dialogue on Telos fix

-Hidden compartment fix

-Imprisonment fix at Atris` academy

-Telos criminals quest fix

-Telos Citadel Station fuel source fix

-Onderon Starport visa fix

-A fix that allows to skip dailogue with Mebla (in Telos Cantina?)

 

Others:

-Exile Saber

-Exile item pack

-Force Power: floating lightsabers (kreia uses in the end fight)

-Mace windu face + items

-Master Armor Robe 2.5

-New Mira skin

-Portable construction table (armband)

-Prestige class bonuses

-Nihilus and Visas introduction cut-scene changed resolution

-Visas teaches Force Sight

-Stormtrooper skin for PC and Sith troopers

-sv

Share this post


Link to post
Share on other sites
These are from the Kotor2 Restoration Project site:

-Dxun puzzle fix

-Jedi Master fix on Dantooine

-Handmaiden dialogue on Telos fix

-Hidden compartment fix

-Imprisonment fix at Atris` academy

-Telos criminals quest fix

-Telos Citadel Station fuel source fix

-Onderon Starport visa fix

-A fix that allows to skip dailogue with Mebla (in Telos Cantina?)

-Visas teaches Force Sight

 

This looks ok unless there is a global variable problem somewhere (I didn't checked that): it's only changes to .dlg files and scripts. (thought the global.jrl file contained in the fuel quest fix will be incompatible with other mods using this file).

 

 

Others:

-Exile Saber

Which one?

 

-Exile item pack

I assume it's Redhawke's item pack ( http://www.pcgamemods.com/10927/ ) If this is the case, this mod shouldn't cause trouble except if you are using other mods that have an upgrade.2da and upcrystals.2da file

Force Power: floating lightsabers (kreia uses in the end fight)
Glad you are using this one :D I made it! There's no way this mod creatres the problems you have. It uses *.utc files but they are custom files and not files that I took from another module. However, make sure you don't have other mods using the spells.2da file or one of the mods will stop working unless you edit the files.

 

-

Mod that gives a lightsaber in the beginning
If it's xcom's mod it's fine but there are many other similar mods.

 

-Master Armor Robe 2.5

-Ossus Keeper Robes

Shouldn't be causing any problems. .*uti and *.tgs files only. At worse they could be overwritten by another mod.

 

-Nihilus and Visas introduction cut-scene changed resolution
I didn't check that mod touroughly but if it's a movie problem, try without the

 

-Stormtrooper skin for PC and Sith troopers
Make sure you are using the Kotor 2 version of this mod. The kotor version shouldn't be causing problems unless you have other mdos using the same .2da files (in which case one of the mods will cease to work as expected unless you edit the files). Read the readme carefully for each mod. While they are from the same author, they both use the same .2da files so check what the author says (from what I know fo Prime, he certainly mentionned something about it).

 

-sv

Share this post


Link to post
Share on other sites

I cleared override-folder of all the K1 files and unknown ones--> didnt help. Shows a blank screen after the movie. Cleared all the files from override--> still didnt help. After deletion of all files loaded back to previous save---> didnt help.

 

I had a bit similar problem once with K1. I was using the Ebon Hawk basement mod, where i can buy and sell new stuff below the "first level." It showed the selection in the elevator where i can go up or down, selected down--> it never got to the "load" part, but just gave a black screen with sounds in the background. Later i noticed that the modules files werent where they were supposed to be-->fixed that--> started working.

 

Could this be like that? It cant find the Telos Citadel Station module or something. The whole thing starts with my arrest, doesnt it. So maybe im missing some file, just a hunch. Because now it shouldnt be a matter of non-working mods, since i deleted them all...

Share this post


Link to post
Share on other sites

FOUND A SOLUTION Read a few other posts here and stumbled upon a crash problem with ati- and laptop-users. Their game kept freezing always after movies. I had that same problem in the past. I fixed it by downloading new drivers for my ATI 9600., the latest cataclyst.

 

Obviously when i re-installed K2 something erased it, because when i disabled movies everything started working again!! :)" Im wondering that how could re-installing K2 change my drivers. Arent they in a completely diffrent folder and used only by my ATI card? Or did the cataclyst add some files to my K2 file???

 

Id like to apologize to Tk102 for needlessly blaming his savegame-editor :"> nevertheless could you still look into the other bug(most likely my mistake) that i had. I just dont know how to create that log file.

 

I cant believe all this trouble for some stupid movie clitch...that i had fixed before! But thank you all for helping me

Share this post


Link to post
Share on other sites
And why is the word: "****pit" sensored.......

 

LOLOLOLOLOLOLOOL

That one made me laugh for 10 minutes. :D

That word is sensored because of the first 4 letters.

LOLOLOLOLOL

Share this post


Link to post
Share on other sites

REALLY! I HAD NO IDEA! Really i know that and i know that this forum is using a program to sensor stuff, but it`s still stupid because that word will be used often in this forum, atleast by me.

Share this post


Link to post
Share on other sites

I will say this once and only once: the word is spelled censor.

 

Also, ask a stupid question, get a stupid answer, SP.


And I find it kind of funny

I find it kind of sad

The dreams in which I'm dying

Are the best I've ever had

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...