Jump to content

Screen Refresh Rate Issues?


Recommended Posts

My desktop is set at 100 Hz screen refresh rate. The highest I can set the game is 85 Hz. Also, the movies are being shown at another refresh rate from what you set your game: 60 Hz, I think?

 

1. Can I set Kotor 2 to 100 Hz in game?

 

2. Can I set the movies to 100 Hz?

 

I am thinking that worst case, I could set the game at 85 Hz, my desktop at 85 Hz, and then someone could tell me how to set the movies at 85 Hz and then I could have some peace :huh:

 

As it stands, I get the change refresh click and blackout every time I start the game (several clicks here, for some odd reason), a movie is shown during play, or even if I Alt-Tab out of the game.

 

Click...Click, blackout, click, blackout, click ... aiiiiieeeee

Link to comment
Share on other sites

It depends what graphics card you are running. Nvidia cards have an option which lets you override the refresh rate. Similarly programs like power strip will let you do that as well.

 

Which ever route you go down, make damn sure that the refresh rate you force is supported by your monitor at that resolution, as it stays forced when you set it. (If you set something that the res can't support, particularly your desktop res, it can screw your system up big time). Also remember that you may need to override the refresh rate for each resolution (the movies are 640x480, regardless of what resolution you play at).

 

Under dxdiag, there's an option under more help to override the direct draw refresh rate (this will help in the game but maybe not in movies.)

Link to comment
Share on other sites

Thank you for the help, adrich81!

 

I am told I have an ATI 9800 PRO. And I went into setting and specified 100 Hz as refresh rate override. I also changed the dxdiag one to 100 Hz, though it seems that it was already set for that (maybe the ATI program did it when I selected override?)

 

My question is this: how do I avoid blowing everything up if I load a program that happens to be in 1280x1024 which has a maximum refresh rate on my computer of 75 Hz. Does this override mean it would try to display that resolution at 100 Hz and cause damage?

 

Thank you!

Link to comment
Share on other sites

Thank you for the help, adrich81!

 

I am told I have an ATI 9800 PRO. And I went into setting and specified 100 Hz as refresh rate override. I also changed the dxdiag one to 100 Hz, though it seems that it was already set for that (maybe the ATI program did it when I selected override?)

 

My question is this: how do I avoid blowing everything up if I load a program that happens to be in 1280x1024 which has a maximum refresh rate on my computer of 75 Hz. Does this override mean it would try to display that resolution at 100 Hz and cause damage?

 

Thank you!

 

 

The movies are done at the xbox resolution... So I don't think you will be able to set it higher.

Link to comment
Share on other sites

go to the game folder, and there you should find the swkotor2.ini file. open it and set your desired resolutions and refresh rates under the following (this is how I got mines set):

 

[Display Options] (for the movies)

FullScreen=1

Disable Movies=0

Disable Intro Movies=0

Sort Modules=1

Width=640

Height=480

BitsPerPixels=32

RefreshRate=100

 

[Graphics Options] (for the game)

Anisotropy=2

Frame Buffer=1

Grass=1

Soft Shadows=0

Shadows=1

Brightness=57

EnableHardwareMouse=1

FullScreen=1

AllowSoftShadows=1

RefreshRate=85

Width=800

Height=600

V-Sync=0

Texture Quality=2

Anti Aliasing=2

Link to comment
Share on other sites

The best way to check is to set your desktop to the desired resolution and have a look under your monitor refresh rates. that will show you exaclty what's supported. It's always best to check. I forced an incorrect rate and killed a crt monitor a few years back.

Link to comment
Share on other sites

Refresh rates above 85 Hz are NOT the problem of monitors/graphics cards, as I discovered. They are a problem of the game itself. There's nothing short of changing the hardcoded limit in the executable (at VA .7B95F0) from 00 00 AA 42 (85.0f) to 00 00 7F 43 (255.0f) or greater to fix this the RIGHT way. After you do this, open swkotor2.ini and change RefreshRate=? (where ? is a number) to RefreshRate=-1 everywhere. This will force the maximum refresh rate that the display driver reports in all video modes. Of course, you will have to change it manually again if you change the game video mode from the menu. The intro movies may be displayed at 800x600 after this, but all other cinematics should still be at 640x480.

 

An easier way is of course to use display refresh rate override, if supported by video driver. nVidia drivers only support in on EDID monitors (I had to cut off my EDID pins because the monitor was being detected correctly 50% of the time). So if your monitor is initially detected as "Default Monitor", you are out of luck with this. You can use the tool called RivaTuner to do refresh rate overrides still, but it will have to remain resident in memory.

 

It is a shame they hardcoded the limit in KOTOR2; in KOTOR, there was no such restriction (you still only had up to 85 Hz in the menus, but you could set it to whatever you wished in the .ini file).

Link to comment
Share on other sites

Those clicks you hear?

 

They are hammering your monitors flyback circuit.

 

That is VERY BAD.

 

You are shortening the life of your monitor substantially.

 

The best solution is to "suck it up" and just play at the max resolution of 85 Hz to keep the monitor from reacting this way.

 

It sucks that the developers didn't actually "port" this game correctly, all other bugs and glitches aside, since anyone who either designs or plays PC video games in the last few years knows that 100 Hz or more is the referred refresh rate for gamers and anyone who sits in front of a PC monitor for extended periods of time (it's better on your eyes).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...