Jump to content

Unified thread - ATI users with Dantooine problems

Recommended Posts

There are a bunch of scattered threads/posts on the topic, thought I'd make it easier to gather all the information in one place.


To clarify, in case folks hadn't noticed, the lag occurs precisely when either one of the manta-creatures or a flock of birds flies overhead. When this happens, framerate drops to nothing.


A work-around is to make a change to the graphics settings. The reason this works is it resets the overhead graphics as well. However, the next time the overhead flying background comes around, the framerate drops again.


The issue is with most ATI cards, but particularly bad with 9800 series. The game runs well elsewhere (except for the cutscene movies, which are awful), but essentially grinds to a halt on Dantooine.


Reported fixes:


--Add the line 'Disable Vertex Buffer Objects=1' to the [Graphics Options] section of swkotor2.ini file in your game directory. I'd suggest trying this first.


--Some users have reported resolving this by rolling back to the 4.1x version of the ATI Catalyst drivers. This goes contrary to Obsidian/LA's suggestions to upgrade to the newest drivers, but has been successful in some cases.


--Changing the graphics settings slightly to reset the display buffer. Works, but very short-term fix and must be done repeatedly.


Status of permanent fix from Obsidian, Lucasarts or ATI: none at this time.


If you find any other information or things that work to fix the problems, please post them in this thread.

Link to comment
Share on other sites

Dragon posted in another thread that adding the following line to the [Graphics Options] section of swkotor2.ini alleviated the frame rate issues. I found that it not only completely cleared up the Dantooine problems on my system, but that also the game in general ran much better and looked a lot nicer. Here's the line:


Disable Vertex Buffer Objects=1


Was like looking at/playing a different game after that change. I'm sad to say that the cut-scene movies show no improvement, but the improvement everywhere else was remarkable. I'll edit the original post to reflect this new information.

Link to comment
Share on other sites

I was really worred about this one, so I went to Dantoine, even though I'm still not finished with onderon. just to check things out.


The big bird flying overhead didn't affect anything for me. btw I have ati 9600 XT, 4.11 drivers. windows xp (not using sp2)


the only problems is the movies are a little quirky. and after several hours the conversations seem a bit laggy. I usually restart the game when this happens. I can't say this bothers me too much, not like Morrowind which I have to restart almost every hour. :ermm:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...