Jump to content

Saves loading current world and inventory but previous character inventory and location

Recommended Posts

Played a few hours yesterday on the new Pond update. Logged into today after the patch and while my base has the correct contents, my player inventory and location is reset to a previous state (losing my pond-specific items). Regardless of which save I load I end up in the same physical location with the same inventory, though my base inventory and structure reflects the correct state based on the save.

I tried renaming my local save folder and after the game re-downloaded from the cloud I still have over 100 folders (which is down from over 400).


Link to comment
Share on other sites

Same issue.  The game is loading me back in before from a save to Friday.  

All my items that I have crafted are gone plus a few others that were crafted before the weekend.

This is also a repeatable issue.

I repaired an item, did a manual save, exited the game completely and then restarted.  I was back at the previous location and item was no longer repaired.  I did this 3 times in a row.

Link to comment
Share on other sites

I was using a game saved in PTS when I had the issues with inventory and multiplayer disconnects. I tried loading a save from before PTS and so far I have had no issues with inventory or second player disconnects. I had all saved inventory in backpack from that save. We've played it a few times and it's been good with those particular issues so far. We are getting "Crunchy Audio" (fixed when restarting game) and items falling through floors, etc.

Edited by MeGamerYouJane
Link to comment
Share on other sites

Adding to bump this thread.

We have the same issue.

It seems like our inventories are stuck as they were in the 0.4.1 patch, and any save during the new 0.4.2 patch doesn't save our inventory layout. I would also like to note that mutations etc. are set back, as well as our characters location on the map.

While our characters are reset, the world is usually fine. Our structures and chests stay. Because of this, we have just been chucking our whole inventories into chests before logging out. 

Thanks for your hard work this game is DEFINITELY my GOTY btw. LOVE IT

Link to comment
Share on other sites

As an update, I wanted to confirm that I tried a save prior to the pond update and it loads correctly -- player location and all. Something is broken or being skipped in the new save/load logic.


  • Thanks 3
Link to comment
Share on other sites

Just replying to add to this thread.

I too am having this issue, I am on PC but own Grounded through the Xbox Game Pass and have downloaded and installed it through the Microsoft Store. 

The issue seems to be present since update 0.4.2, and causes my character progress and location to revert back to an older save, whilst the world progress is correct and as I left it (recent builds, item storage, etc are all ok and as they were left).

This is also affecting things like mutations, so any recently unlocked/upgraded mutations revert back to the same point as well. As far as I can tell this is only affecting character progress.

Link to comment
Share on other sites

Same issue happening to me. 

Game from PC Game Pass. 
I am the host. 
My friend plays from steam. 

Every time I load I am dragged back to the Hedge, the place I was before the patch was released. With the items I had back then in my pockets, and everything I had disappeared. Any new mutations gone. 

My friend does load correctly where he last left it. With his items. 

Everything that has been left on the chests is there. 

I tried erasing every saved game in which I was in the Hedge, and left only the new save games. But I am still taken back to the Hedge in the same conditions every time I load game. 

I tried reinstalling the xbox app, I tried reinstalling the game, I tried not letting the game synchronize. 

Same results all the time. 

If I save and without leaving the game completely I load the game, everything seems to be fine. But after leaving the game, the saved progress goes corrupt or something. 

Has anyone found a way around that it's not leaving everything in chests? I am quite far away from the new content and my friend and me have very short time normally to play. So it's barely unplayable in these conditions... 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...