Jump to content
  • 0
Sign in to follow this  
dodger2020

Game crashes on startup - steam

Question

Posted (edited)

Played and finished POE2 back when it first came out.  Took my sweet time and put around 83 hours into it.  Decided to give it another go with the turn-based system as that's my preference anyway.  Crashes on start every time.    Ryzen 1800x (not overclocked), 16gb, 1080ti. Hardware-wise, nothing has changed since I installed the game originally.  This is on the latest Windows 10 update with the latest nvidia driver. Nothing has made any difference so far. Uninstalled, reinstalled the game.  verified game files (no issues). removed / updated to the latest nvidia drivers. deleted save folder.  Deleted everything Pillars of Eternity II related in the registry.  Turned off steam cloud sync.  Turned off firewall (also tried exiting the firewall completely), turned off windows defender.  run as administrator. Changed the install folder from d: to c:.  Made sure nothing is read-only although not sure why it would be.  Also tried changing my primary display back to my 1080p monitor instead of the 4k.  Even tried the beta version.  Disabled any other programs that started up.  Nothing makes any difference.  Crashes almost instantly.  I was one of the few at release that had zero issues with the game other than a single crash. 

 

I thought it'd be related to nvidia in some way but there was another guy with the exact same issue but with an amd rx580.  In the output log of the single crash I had in may of last year it starts with the

"Initialize engine version: 5.6.3p3 (88d4ddf6344a)
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 11.0 [level 11.1]
    Renderer: NVIDIA GeForce GTX 1080 Ti (ID=0x1b06)
    Vendor:   NVIDIA
    VRAM:     11127 MB
    Driver:   23.21.13.9077"

 

Where as the current crash issue starts with

"Initialize engine version: 5.6.3p3 (88d4ddf6344a)
GfxDevice: creating device client; threaded=1
Crash!!!"

 

Ideas?  I'm going to try uninstalling the nvidia driver with the latest version of DDU and reinstall it once more but I don't have high hopes since I've done it once at the very beginning of troubleshooting.  Edit: As expected, no change. Crashes instantly whether starting from steam or from the exe directly. 

error.log output_log.txt crash.dmp DxDiag.txt

Edited by dodger2020

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Citrix Workspace which I occasionally have to use for work was the culprit.  Even though it wasn't running and I made sure there were no citrix processes running, just having it even installed was preventing the game from working.  FWIW, I have had no problems with any other unity games running just fine.  Just this one.   What a hassle.

Share this post


Link to post
Share on other sites
  • 0

@dodger2020

In case you haven't found the thread of recommended solutions for Citrix-related problems, the easiest thing right now is to completely uninstall Citrix, then reinstall Citrix Workspace through the Microsoft Store.  The App store version omits the virtual video drivers that currently crash Unity 5.6 games.  It does the same thing as workarounds like this, but does not need to be repeated every time Citrix releases an update. 

If you're just remoting into systems for work, you are unlikely to need the drivers or the "Citrix Casting" feature.  It is designed for a very specific set of use cases, like mobile roaming or logging into a projection system via QR codes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...