Jump to content
  • 0

Cut-scene hang in Temple of Relevation


Question

I'm moving from Scriptorium to Temple of Revelation. When I enter the temple 2 cut-scenes play:

 

1. Cut-scene about an egg hatching

2. Cut-scene between Tayn and an imp playing dice

 

The 2nd cut-scene hangs forever. Since there is no where else to go (the only place to go from the Scriptorium is the Temple of Revelation) my game is now unplayable.

 

 

Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

Hello PensivePenguin,

 

Thanks for bringing this up, I'll get this handed over to QA and see if it can be reproduced and if so get a bug in. In the meantime, if you could get a save file sent to support.obsidian.net we may be able to help in our investigations.

 

Best,

 

-Caleb

I like big bugs and I cannot lie...

Link to post
Share on other sites
  • 0

The save is too long, I will email it. But here is the output log (attached). It looks like it hits the same error each time.

 

NullReferenceException: Object reference not set to an instance of an object
  at Game.Item.GetSpriteIcon () [0x00000] in <filename unknown>:0 
  at Game.ItemMod.GetSpriteIcon () [0x00000] in <filename unknown>:0 
  at Game.StatusEffectInstance.GetSpriteIcon () [0x00000] in <filename unknown>:0 
  at Game.StatusEffectInstance.CacheOrigins () [0x00000] in <filename unknown>:0 
  at Game.StatusEffectInstance.OnAdd (IStatusEffectTarget target, IStatusEffectOrigin origin, Boolean skipResistance) [0x00000] in <filename unknown>:0 
  at Game.StatusEffectManager.AddEffect (Game.StatusEffectInstance newStatusEffect, IStatusEffectOrigin origin, Boolean skipResistance) [0x00000] in <filename unknown>:0 
  at Game.StatusEffectManager.AddNewEffect (Game.GameData.StatusEffectGameData gameData, IStatusEffectOrigin origin, Boolean empowered, Single shapeAdjust, Boolean skipResistance) [0x00000] in <filename unknown>:0 
  at Game.StatusEffectEvents.OnEventApplyStatusEffects (Game.StatusEffectInstance statusEffect, Game.DamageInfo damageInfo) [0x00000] in <filename unknown>:0 
  at Game.StatusEffectEvents.FireEvent (Game.StatusEffectInstance statusEffect, StatusEffectEventType triggerEvent, Game.DamageInfo damageInfo) [0x00000] in <filename unknown>:0 
  at Game.StatusEffectInstance.NotifyEvent (StatusEffectEventType eventType, Game.DamageInfo damageInfo) [0x00000] in <filename unknown>:0 
  at Game.StatusEffectInstance.ClearEffect () [0x00000] in <filename unknown>:0 
  at Game.StatusEffectInstance.OnClear (Game.StatusEffectManager manager) [0x00000] in <filename unknown>:0 
  at Game.StatusEffectManager.ClearStatusEffect (Game.StatusEffectInstance baseInstance, Boolean isCounter, Boolean clearStacks) [0x00000] in <filename unknown>:0 
  at Game.StatusEffectManager.ClearStatusEffectsByOrigin (IStatusEffectOrigin origin) [0x00000] in <filename unknown>:0 
  at Game.ItemMod.RemoveEquipEffects (UnityEngine.GameObject character, Game.Equippable equip) [0x00000] in <filename unknown>:0 
  at Game.Equippable.DestroyItemMod (Game.ItemMod mod) [0x00000] in <filename unknown>:0 
  at Game.Equippable.DestroyAllItemMods () [0x00000] in <filename unknown>:0 
  at Game.Equippable.Destroy () [0x00000] in <filename unknown>:0 
  at Game.WeaponSet.DestroyAll () [0x00000] in <filename unknown>:0 
  at Game.EquipmentSet.DestroyWeapons () [0x00000] in <filename unknown>:0 
  at Game.EquipmentSet.DestroyAll (Boolean includeWeapons) [0x00000] in <filename unknown>:0 
  at Game.Equipment.OnyxDestroy () [0x00000] in <filename unknown>:0 
  at Onyx.OnyxBehavior.OnDestroy () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)
 

output_log_crash.txt

Link to post
Share on other sites
  • 0

Hey,

 

I recently ran into this same issue. Upon leaving the Scriptorium for the Temple of Revelation, the game gets stuck after the second cut-scene. I tried to circle back to the Temple by backtracking through the Collections area, but the way back there is blocked after engaging the boss in The Assembly of Echoes.

 

One thing I found noteworthy was that upon loading the scene in the Temple, the camera abruptly moves from the party over to Tayn and the imp and stays there. Also, the dialogue options during the Egg scene also cannot be selected by using the keyboard. After these two cut-scenes neither the mouse or the keyboard can be used for inputs, but the game does not outright crash. Instead I have to input either Alt+F4 or shut the game through the Task Manager.

 

I've uploaded the save game, as well as one from just before I enter the Temple onto Google Drive. The output log can also be found there. Judging by its contents, the game seems to run into the same issue as it does on PensivePenguin's side.

The Drive folder can be found here.

 

Thanks for the help,

Pringlos

Link to post
Share on other sites
  • 0

I'm having this issue as well. Given the length of time this issue has stayed open, I guess that ends my play through of the Pillars games 😕

 

Dropbox link for save game  https://www.dropbox.com/s/b8q7lijsfhmxka7/Reyne (978c851e-3c07-4376-80bb-666d5bdb3567) (LAX-123ABCDEFGHI) autosave_0.savegame?dl=0. Output log attached. I'm not sure its the exact same issue though.

 

output_log.txt

Link to post
Share on other sites
  • 0

I have the same bug. Moving from the scriptorium to the temple of revelation and the game is stuck after the cut scene / dialog between tayn and the imp about dice.

I got rid of the egg in the scriptorium so it’s doesn’t appear to be related to the cut scene about the egg.

It’s game breaking (and I didn’t go to Ukaizo, and can’t now :( )

Edited by Gundarf
  • Like 1
Link to post
Share on other sites
  • 0
On 10/23/2020 at 2:56 PM, BALONEYPWNY said:

For posterity:  I loaded the autosave that triggers when going down the stairs just to see what would happen, and the cutscene played out without hanging up.  I hope this works for everyone else suffering this issue.

Tried that like a dozen times... Also tried loading older savegames before entering the dungeon in front of the library and even before entering the whole island. Ran in the same problem every time. 

Looks like that DLC is broken.

Link to post
Share on other sites
  • 0
On 12/7/2020 at 7:22 PM, Filz said:

Tried that like a dozen times... Also tried loading older savegames before entering the dungeon in front of the library and even before entering the whole island. Ran in the same problem every time. 

Looks like that DLC is broken.

Ha! Solved it! 

This happens only if you free Bekarna and NOT visit her in the temple before fighting this thing in the room full of bodies. 

So load an autosave before the fight, go to the temple and it will trigger the exact same cut scene. Just without the problems. 

Now you can go back, fight the thing and finish the game. 

Link to post
Share on other sites
  • 0
On 1/27/2019 at 3:58 PM, PensivePenguin said:

I'm moving from Scriptorium to Temple of Revelation. When I enter the temple 2 cut-scenes play:

 

1. Cut-scene about an egg hatching

2. Cut-scene between Tayn and an imp playing dice

 

The 2nd cut-scene hangs forever. Since there is no where else to go (the only place to go from the Scriptorium is the Temple of Revelation) my game is now unplayable.

 

 

I have the exact same problem.  I have to admit that I am really disappointed to have put over 100 hours into this game and it has to end like this.  I don't have an autosave early enough to avoid this, and my last manual save is ten hours earlier.

I hope a fix is issued eventually.  I would love to actually be able to finish this game.  🙁

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...