Jump to content
  • 0

Game crash almost every time I load a new location/save



Hi all. As above, a pretty common issue as I seen, I tried a lot of things to get through it, but still no solution with the standard suggested metods. I purchased the game 2 days ago, so it is the latest version; no background applications while i run it; the pc memory is cleaned with Advanced SystemCare; lowest graphic settings for the game.

See if someone can read throught the crash logs to find where is the problem, I attached a couple of them. Thanks in advance for every suggestion.

System specs also attached. Save file too big to get attached, but right now I'm trying to enter the catacombs, a location that seems to be one of the most problematics; I also can't get to my fort, while I managed to enter almost all others locations after a couple of crashes, sometime I enter, sometime I crash, but you all understand that the game is unplayable in this state.





Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...