Jump to content
  • 0

5.5 Into the Runeforge... but not quite... Please Help!



BlueStacks Emulator



No pass/play or permadeath

Story Mode

Seoni, Valros, Lini, Harsk, Kyra, Ezren in party, that turn order.

Location - after completion

Normal difficulty, Scenario 5.5 Into the Runeforge



OK, I didn't notice until after this occurred that Ezren hadn't completed 5.3, so maybe that has something to do with this, BUT -


I finished the adventure and every character but Ezren was awarded the Runeforged Weapon Loot card.

Every character was then able to make a new selection from the Cards List, but then I am completely stuck.


Due to the additional card options, and the way things played out (like Valeros playing the charmed dragon ally and me rolling a 1 and having him banished) all of my characters need cards to complete their decks.

Also, this being my first time through 5.5, I don't know how this is supposed to go and if I'm supposed to get the Runeforged Weapon card for all my decks or what...


At any rate, I am able to discard the cards I have OVER my set limits, but I cannot get access to the other cards available for me to choose & add them to my decks.

I am 2 weapons,  2 items, and an ally short, but the arrow to 'proceed' is unlit, and I cannot do anything to advance past this screen.


Please help!



Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

The Runeforged Weapons are a passive bonus, so it shouldn't show up in the card lists. Have you tried tapping the unlit arrow anyway? Also, make sure you don't have any of the cards left over from other decks. You have to use those first before you're taken to the free card selection screen.


Did Ezren fall unconscious during the scenario? That way he wouldn't get the rewards and needs to go back and try to win the scenario.

Link to comment
Share on other sites

  • 0

When I have a missing card count to resolve I find that the most reliable way to get it to progress is to select the character with a missing card and hit the button at the bottom of the screen that matches the missing card type. At this point it usually populates the available cards row and everything works OK. It's not normally necessary to hit the "advance" button to trigger the card selection at the end of a scenario IME.

Link to comment
Share on other sites

  • 0

Thanks for your replies!

Actually, aside from maybe my first week of playing I haven't run into an issue of running out of cards with any character, so no unconscious/death going on.

I tried everything I could think of, and clicked everyplace I could, and never got this resolved, so I had to delete the party, which wiped all of my completions at Legendary.


Oddly enough, when I started a new party with the same members, I started out with the same # of cards from the adventure I was stuck at, so some of my characters actually had MORE in their decks than they were supposed to!

(I know, a bug, whoda thunk it?)

Also, somehow I ended up with 2 Wands of Enervation!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...