Jump to content
  • Sign Up
  • 0
Justinian

Terrible Frame Rate still hasn't been fixed?!

Question

So I've been putting this game off since it came out because of terrible frame rate in various areas and during every combat encounter. When I pledged for this game it never crossed my mind that a 2.5D game would ever perform so poorly. After checking back every single patch to see if things have improved and seeing nothing, I'm at wits end. During the year or so the game has been out, I have upgraded my PC from a i5 2500k/HD 6950 to an i7 6700/GTX 980 Ti, and to my utter dismay, I saw almost negligible performance improvement.

 

I was briefly relieved that Copperlane began running at 60fps right after the 3.0 patch, but after a little while playing, the performance dropped back to the usual crap (some kind of memory leak at work I'm sure). The thing is, I could probably tolerate certain areas running at 45fps, but the combat in this game routinely drags performance down to the 20s and 30s when spells go off, making the game a sluggish mess and nigh unplayable.

 

I'm almost certain that others are suffering the same performance issues so why isn't anyone complaining here? Obsidian, are you just going to leave the game as is and completely ignore optimisation? Sure, the support you've given the game content wise is admirable but why hasn't something central like performance been paid any attention? As entitled as I may sound, I would like a dev response to clarify just what is going on, as I'm sick of waiting to play this game I pledged hundreds of dollars for and years looking forward to.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

The game isn't exactly well optimized but I've never gotten quite as abysmal a performance as you describe. During clusterf**k battles yes, I get down to 35-40 fps but not randomly while walking through Copperlane.

 

i7 4790k / GTX 970


"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke

Share this post


Link to post
Share on other sites
  • 0

I have to agree with the OP, and it is frustrating that this issue is still going on.  Framerate drops are particularly bad in areas of multiple characters/NPCs.  Just with my party alone, taking out party members yields a change in 10 fps.  It's ridiculous, particularly if you have a high end system.  This game is not that demanding.  There's no excuse for it.  I noticed the decrease in performance when the patch with white march part one came out.

 

The worst area for me is entering Cragholdt bluffs.  As soon as I enter the area I'm starting out at 44-47 fps.  As soon as battle starts, it goes down to 22-36.  This is horrible.  Most of the game plays above 60 fps for me. 

 

With the release of the white march 2 expansion and the new patch, I was hoping some of this would be fixed.  But nothing changed.  Its bad enough for me to decide not to purchase white march part 2. 

 

Come on, Obsidian... fix this!

Edited by kmansp
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Agree with OP, very poor performance, although the latest patch improved Copperlane a little for me.

 

From a little testing, I've noticed that the Copperlane FPS has increased in this patch:

i5-3570K @ 4.3GHz + Radeon R9 280X 3GB:

2.03: 39 FPS

3.00: 52-55 FPS

 

My older machine

Intel Core 2 Quad @ 3.1GHz + Nvidia GTX750

2.03: 20 FPS

3.00: 25-26 FPS

 

The problem from what I can tell, isn't really the graphics card (changing graphics settings or AA levels has zero effect).  Opening up GPU-Z with PoE running shows ~ 20% GPU utilization (i5-3570K system)  in Copperlane, despite the low FPS. 

 

TL;DR it seems that CPU performance is much more important than your graphics card performance.

 

Do any of you recall the pre-GPU era of graphics cards eg Voodoo 2 3dfx, Nvidia Riva TNT 2?

 

Then Nvidia came along with it's GeForce 256 with hardware Transform and lighting and suddenly we could enjoy more detail as what was done on the CPU traditionally was offloaded onto the GPU.

 

It feels like the 3D engine is offloading too much of the rendering to the CPU for some reason...but it could equally be some loop/s are consuming a huge amount of CPU resources.

 

Something is eating up CPU performance.

Share this post


Link to post
Share on other sites
  • 0

Why is there no official reply on this? This is the only reason I'm not playing (or buying expansions for that matter). 

Share this post


Link to post
Share on other sites
  • 0

Having similar issues. I was locked at 60 fps with 1080ti and r7 1700x. I recentlt downgraded to a 1060 6gb (money issues) and an r5 1600. Thats still a decent gpu and 12 threads clocked at 3.9ghz is alot. However im getting 35fps at 4k and dips in combat to single digits. At 1080p res i only gain 3fps thus why i left it at 4k. Cpu usage has hit an impressive 60% (alot for a game) but gpu usage has never been higher then 30%. It doesnt seem to actually be using the system much.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...