Jump to content
  • 0
Sign in to follow this  
exo

A couple of screen related quirks in Linux

Question

Hello, I encountered a couple of quirks in the Linux version. I'm reporting them together as they might or might not be related.

 

Issue #1 : Game sets the windowed (non-fullscreen) mode only very reluctantly, and refuses to remain in it.
I want to run the game in 1920x1080 windowed mode, but if I simply remove the full screen option checkmark (and press Apply), the game just flat out refuses to get out of fullscreen. The only way to set a windowed mode is to 1) first set a lower resolution with fullscreen mode, then 2) press Apply, then 3) set it back to 1920x1080 without the fullscreen mode and 4) press Apply again. These settings can then be saved correctly in preferences upon saving (see spoiler for details), but when I exit the game and start it again, it once again starts up in fullscreen, so I have to repeat steps 1-4 again every time I start up the game.

These are the desired screen settings in the pref file:

<pref name="Screenmanager Is Fullscreen mode" type="int">0</pref>
<pref name="Screenmanager Resolution Height" type="int">1056</pref>
<pref name="Screenmanager Resolution Width" type="int">1855</pref>

 

The attached file Player.log.start_with_desired_resolution.txt shows what happens when these options are enabled in the prefs file. Basically it appears to try it out, fail for some reason (the log does not have enough details to tell why exactly) and finally revert to 1920x1080 fullscreen.

 

 

 

Issue #2 : Game crashing/failing to restart when the graphics quality option is set to highest.
If I set the graphics quality to its highest setting (corresponding to the line '<pref name="Quality" type="int">2</pref>' in prefs), the game fails to start at all. The attached file Player.log.crashes_with_high_quality.txt shows what happens when trying to start the game with this option enabled.
 

Otherwise the game appears to work well. Neither of these issues are showstoppers, but they are not merely cosmetic either (it took quite a while to work around the windowed mode issue, and to find out which option exactly caused the crashing).

 

My system specs:

 

OS: Linux 3.19 Ubuntu 15.04 64bit
CPU: Intel® Core™ i7-4810MQ CPU @ 2.80GHz × 8
System RAM: 15967
GPU: GeForce GTX 870M/PCIe/SSE2 GPU RAM: 3072
GPU Driver: NVIDIA binary driver - version 355.06

It's an Optimus laptop and I'm using Bumblebee, but I doubt it has anything to do with these issues, as all the other games (about 20)  in my Steam library work flawlessly.

 

 

  • Like 2

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Thanks for being considerate and using spoiler tags! Welcome to the board and enjoy your stay. After five posts, you'll no longer be moderated and posts will go through without needing approval. Hopefully you stick around and enjoy debating, describing, or otherwise discussing your experiences with PoE and other games. I'll leave the answer to your question to folks more in the know than me.

  • Like 1

Fionavar's Holliday Wishes to all members of our online community:  Happy Holidays

 

Join the revelry at the Obsidian Plays channel:
Obsidian Plays


 
Remembering tarna, Phosphor, Metadigital, and Visceris.  Drink mead heartily in the halls of Valhalla, my friends!

Share this post


Link to post
Share on other sites
  • 0

I am running Linux too with a 1080p monitor so I'll go ahead and try this on my machine when I get home.

If you run the game from a terminal you should also see if you are getting errors.

 

> Resolution: Can reproduce this issue - but I don't get any errors in the terminal. Cannot find any kind of log in the game folders to check (didn't load a game, did this from title screen)

Basically - If you untick fullscreen, click apply, nothing happens. Leave options and go back and the option is ticked again, so this option isn't "sticking". If you reduce the resolution as per the OP it reduces, but if you then untick the full screen option and hit apply, you see it windowed for a split second and then it reverts to native resolution in full screen. Something is not sticking properly here. Maybe the changes are being written to the wrong place or something. If someone can point me to the config file so I can edit and see if that forces it that would be great.

 

> Graphics all the way up

Ok, tested this and it works for me, game opens fine. This one I suspect is a driver or library issue. First thing - are you using the proprietary nvidia drivers? If not, please try them.

You can also use ldd to check if there are any missing/broken libraries that the PoE depends on.

Do this -

 

 

In a terminal, navigate to the install location of the game, if it's through Steam it should be:

cd ~/.steam/steam/SteamApps/common/"Pillars of Eternity"

Then do:

ldd PillarsOfEternity

 

Output should look something like:

linux-vdso.so.1 =>  (0x00007fffe0dda000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f538aa0c000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f538a7ee000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f538a5e6000)
        libGLU.so.1 => /usr/lib/x86_64-linux-gnu/libGLU.so.1 (0x00007f538a378000)
        libGL.so.1 => /usr/lib/fglrx/libGL.so.1 (0x00007f538a17c000)
        libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f5389e47000)
        libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007f5389c3d000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f5389939000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f5389633000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f538941d000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f5389058000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f538ac10000)
        libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f5388e46000)
        libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f5388c27000)
        libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f5388a1d000)
        libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f5388817000)
        libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f5388613000)
        libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f538840d000)

 

This will tell you if any library links are buggered, or if your system is using different ones to mine.

 

 

 

My hardware:

 

 

Kubuntu 14.04.3 LTS (fully up to date)

MOBO: Z87-D3HP, CPU: i5-4690K, RAM: 8GB DDR3, GPU: R9270X 4GB, SSD: 1TB 840 EVO

Graphics drivers are the fglrx (amd proprietary) ones from the *buntu repos

 

Edited by haveahappy
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hey haveahappy, thanks for checking this out! :)

 

> Resolution: Can reproduce this issue - but I don't get any errors in the terminal. Cannot find any kind of log in the game folders to check (didn't load a game, did this from title screen)
Basically - If you untick fullscreen, click apply, nothing happens. Leave options and go back and the option is ticked again, so this option isn't "sticking". If you reduce the resolution as per the OP it reduces, but if you then untick the full screen option and hit apply, you see it windowed for a split second and then it reverts to native resolution in full screen. Something is not sticking properly here. Maybe the changes are being written to the wrong place or something. If someone can point me to the config file so I can edit and see if that forces it that would be great.

This is exactly the behavior I'm seeing -- in the OP I did omit describing what happens if one unticks the full screen option first, but yes that's how it behaves for me too.

I'm not sure what you mean by the the config file, the only modifiable config file I know of is the prefs file (in the same directory as the Player.log) which does change when you save the changed options, and according to Player.log the game does seem to attempt to switch to windowed mode when starting the game using these options. Therefore I would find it logical to presume that the options are written in the correct place, but of course it's always worth checking.

I do not seem to be able to edit my own posts yet (due to the 5 message limit probably), I did omit one config line from the spoiler in OP so I'll reproduce those here in full:


The file is '~/.config/unity3d/Obsidian Entertainment/Pillars of Eternity/prefs', the relevant lines seem to be:

<pref name="FULLSCREEN" type="int">1</pref>
<pref name="Screenmanager Is Fullscreen mode" type="int">1</pref>
<pref name="Screenmanager Resolution Height" type="int">1056</pref>
<pref name="Screenmanager Resolution Width" type="int">1855</pref>

 


 

> Graphics all the way up
Ok, tested this and it works for me, game opens fine. This one I suspect is a driver or library issue. First thing - are you using the proprietary nvidia drivers? If not, please try them.

My full specs are in the OP (inside the spoiler); the laptop model is MSI GT70 2PC.  I'm currently using the proprietary NVIDIA binary driver version 355.06. It's not the most recent version (released at the end of August, I think the most recent ones at the time of writing are 358.16 and 352.63, both released last month).

 

I know you did not suggest upgrading, but I want to discuss the matter of driver upgrades anyway. :) Of course I'm more than happy to help resolving this, but I'm a bit hesitant to attempt shot-in-the-dark driver upgrades, i.e. before knowing more about the issue, and without a good idea about what one expects to be fixing. This is based on a couple of reasons:

  • My update experiences with NVIDIA binary drivers have not always been roses, hugs and bunnies. Usually the update goes without any issue, there's always a risk of something going wrong, and with NVIDIA -- especially in the case of an Optimus laptop -- when things go south they go south in a big way, usually resulting in several hours of extra work at a minimum :)
  • This current driver version works perfectly with other games, including but not limited to: Bioshock Infinite, Company of Heroes 2, Metro Last Light Redux, The Talos Principle, XCOM: Enemy Unknown and Shroud of the Avatar (which is built on Unity 5 - I think PoE is Unity 4?). Most of these are much more graphically intensive games (and I've tried them all with max settings just for the sake of it, they might be too slow to be playable at max settings but they do not crash), so I would deduce from this that if I had something really missing or broken in the library department, I would already have noticed it.
  • I don't really see anything in the changelogs of later drivers that would indicate that upgrading would actually help. Of course being sure about this would require more information about what the Quality=2 option actually does in Linux (compared to Quality=1), what exactly does get broken?

Sometime later I will upgrade to the latest Ubuntu version and the latest NVIDIA drivers anyway, but unfortunately the upgrading process with Optimus laptops (at least with this particular model) is neither straightforward nor without risks, and I need it constantly  for more serious things than games, so it will take some time (maybe some weekend with enough spare time in case anything goes wrong).

 

You can also use ldd to check if there are any missing/broken libraries that the PoE depends on.
Do this -


In a terminal, navigate to the install location of the game, if it's through Steam it should be:
cd ~/.steam/steam/SteamApps/common/"Pillars of Eternity"
Then do:
ldd PillarsOfEternity

Output should look something like:
linux-vdso.so.1 => (0x00007fffe0dda000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f538aa0c000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f538a7ee000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f538a5e6000)
libGLU.so.1 => /usr/lib/x86_64-linux-gnu/libGLU.so.1 (0x00007f538a378000)
libGL.so.1 => /usr/lib/fglrx/libGL.so.1 (0x00007f538a17c000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f5389e47000)
libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007f5389c3d000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f5389939000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f5389633000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f538941d000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f5389058000)
/lib64/ld-linux-x86-64.so.2 (0x00007f538ac10000)
libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f5388e46000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f5388c27000)
libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f5388a1d000)
libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f5388817000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f5388613000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f538840d000)


This will tell you if any library links are buggered, or if your system is using different ones to mine.

 

Yes that's a good idea. My output from 'ldd PillarsOfEternity' is here:

linux-vdso.so.1 => (0x00007ffc21b9b000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f371908e000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f3718e70000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f3718c68000)
libGLU.so.1 => /usr/lib/x86_64-linux-gnu/libGLU.so.1 (0x00007f37189fa000)
libGL.so.1 => /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 (0x00007f3718762000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f3718429000)
libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007f371821f000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f3717f10000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f3717c08000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f37179f2000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f3717628000)
/lib64/ld-linux-x86-64.so.2 (0x00007f3719292000)
libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f37173ff000)
libglapi.so.0 => /usr/lib/x86_64-linux-gnu/libglapi.so.0 (0x00007f37171d1000)
libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f3716fbf000)
libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007f3716dbc000)
libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f3716bb6000)
libX11-xcb.so.1 => /usr/lib/x86_64-linux-gnu/libX11-xcb.so.1 (0x00007f37169b4000)
libxcb-glx.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-glx.so.0 (0x00007f371679d000)
libxcb-dri2.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri2.so.0 (0x00007f3716598000)
libxcb-dri3.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri3.so.0 (0x00007f3716395000)
libxcb-present.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-present.so.0 (0x00007f3716192000)
libxcb-sync.so.1 => /usr/lib/x86_64-linux-gnu/libxcb-sync.so.1 (0x00007f3715f8c000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f3715d6d000)
libxshmfence.so.1 => /usr/lib/x86_64-linux-gnu/libxshmfence.so.1 (0x00007f3715b6b000)
libXxf86vm.so.1 => /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 (0x00007f3715965000)
libdrm.so.2 => /usr/lib/x86_64-linux-gnu/libdrm.so.2 (0x00007f3715756000)
libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f371554c000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f3715348000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f3715142000)


I lack the expertise to tell if there's something funky with these dependencies, but at least I don't see anything missing?

 

 

Perhaps it's worth repeating, that I'm not personally worried about this particular issue in the sense that I can play the game just fine with Quality set to 1 (medium), but it can be extremely confusing for a new player encountering this kind of issue: One tunes up certain options (including upping the graphical quality), and poof! - from then on, the game crashes, with no obvious clue as to why. Not pretty, especially if one happens to be not that technically savvy, or used to troubleshooting or editing raw config files (the only options to get back into game when this happens, are 1) editing the prefs file by hand, 2) deleting it, or 3) doing a complete reinstall) . So I want to help out fixing it, and I'd appreciate more information about the root cause, and suggestions about how to test it further :)

Share this post


Link to post
Share on other sites
  • 0

Can you run the game from a terminal to see what errors are produced when you try to start the game?

 

Just do alt+Ctrl+T and type "steam" and after the game failing to open, copy all the contents of the terminal out (highlight and press Ctrl+shift+C)

Share this post


Link to post
Share on other sites
  • 0

Can you run the game from a terminal to see what errors are produced when you try to start the game?

 

Just do alt+Ctrl+T and type "steam" and after the game failing to open, copy all the contents of the terminal out (highlight and press Ctrl+shift+C)

Certainly, this is actually now I normally run steam because I prepend it with 'primusrun' (=bumblebee command to force the use of the NVIDIA GPU in Optimus laptops) and I like to see the terminal messages.

 

Nothing exciting really - it just displays the usual paths (path to the PillarsOfEternity binary and 3 Mono paths) that all contain what they're supposed to. It's exactly the same as when it works without crashing (i.e. if setting Quality=1 in preferences). When starting the PillarsOfEternity binary directly from terminal, I get an added "Aborted (core dumped)."

 

 

$ primusrun ./PillarsOfEternity
Set current directory to /home/helm/.steam/steam/steamapps/common/Pillars of Eternity
Found path: /home/helm/.steam/steam/steamapps/common/Pillars of Eternity/PillarsOfEternity
Mono path[0] = '/home/helm/.steam/steam/steamapps/common/Pillars of Eternity/PillarsOfEternity_Data/Managed'
Mono path[1] = '/home/helm/.steam/steam/steamapps/common/Pillars of Eternity/PillarsOfEternity_Data/Mono'
Mono config path = '/home/helm/.steam/steam/steamapps/common/Pillars of Eternity/PillarsOfEternity_Data/Mono/etc'
Aborted (core dumped)

 

 

However, it now occurred to me that since this is an Optimus machine (with two GPUs) there is actually a way to verify if the issue is at least loosely associated with the NVIDIA drivers: I can force any process to make use of either GPU (NVIDIA or Intel). In normally never use Intel with games but...

 

When forcing the game to use the integrated Intel GPU, the game does indeed start without crashing even with the highest graphics quality settings. However this does not necessarily tell anything much, as using the low-power Intel GPU seems to disable quite many graphical features, so the situation might in practice be very similar to setting Quality=1:

 

An excerpt from the Player.log when using the Intel GPU:

GL: disabling shadows on Intel 9xx (buggy)
GL: disabling framebuffer blit, antialiasing, SRGB on Intel

 

 

 

I have attached three Player.log files, see the spoiler for details - there is some added debug info that might or might not help.

In these Player.log files the 'Quality' option is set to '2' and the PillarsOfEternity binary is run directly from terminal after deleting the old Player.log file.

 

The game behaves differently depending on the GPU: When the game is made to run with the Intel GPU, the game starts, and then I simply exit the game and get the log. When the game is made to run with the NVIDIA GPU, the screen just flashes a few times, showing the gloved hand cursor very briefly before crashing.

I'm afraid I can't get much more out of these logs with my skills. The following lines in the nvidia "normal" log look somewhat interesting though:

XError: BadDrawable (invalid Pixmap or Window parameter) (error 9, opcode 153/12, serial 265, XID 04800008, display 0x7f34ac0008c0
XError: BadDrawable (invalid Pixmap or Window parameter) (error 9, opcode 153/7, serial 266, XID 04800008, display 0x7f34ac0008c0

Additionally there are some pixel buffer warnings that might or might not be relevant, moreover in the most recent nvidia driver changelogs there are some pixel buffer related fixes but I really can't say if they are related at all. Anyway:

primus: warning: recreating incompatible pbuffer

 

 

 

I'll try to find some time to upgrade the nvidia drivers sometime this week or weekend, to see if that helps with the issue.

Share this post


Link to post
Share on other sites
  • 0

Yeah it appears to be a driver issue then.

 

That's really a shame, I know my card took more than a year to be probably supported after I built my machine, so I know what it's like to have to mess around installing drivers manually and running config etc to get it right.

I was a happy man when the working versions hit the repos.

 

EDIT: is there a setting in options to turn shadows off? This is usually what breaks things IME, especially at higher settings.

Edited by haveahappy

Share this post


Link to post
Share on other sites
  • 0

Yeah it appears to be a driver issue then.

 

That's really a shame, I know my card took more than a year to be probably supported after I built my machine, so I know what it's like to have to mess around installing drivers manually and running config etc to get it right.

I was a happy man when the working versions hit the repos.

 

EDIT: is there a setting in options to turn shadows off? This is usually what breaks things IME, especially at higher settings.

 

Forgive me for feeling a bit stubborn original.gif

...but I still think the probability of this being a driver issue goes toe to toe with it being, say, some kind of Unity 4 Linux quirk issue.

 

I base my stubborness on the fact that so far my card (GTX 870M) has actually been extremely well supported in Linux for about 1½ years already -- in the sense that I have been able to throw just about any available title at it with almost no hiccups, including shadows and all the available eye candy. Pillars of Eternity is the first game (out of about 20 Steam game titles) to have any major problems. (there are some boring details about it in the spoiler, feel free to skip them)

 

Optimus is actually quite a nice nice idea in a laptop, as a battery powered device and a constantly operating power-hungry GPU is not exactly marriage-made-in-heaven material. The challenge, at least in less-than-optimally-supported Linux, is to make it work in the first place. My problems have been exclusively related to exactly this - getting it to work at all in the first place. Nouveau (the open-source alternative to proprietary NVIDIA drivers) essentially bricks the entire laptop by just being in the same room, and the stability of the various proprietary NVIDIA versions has not exactly been something to bet one's life on. This also makes automated upgrades a BAD idea -- as an example, some apparently "routine" upgrade black-screened my entire 14.04 LTS installation about a year ago, and I finally (after a couple of days of grief, frustration an hair-pulling) ended up installing a short support cycle versions from scratch (there was some kernel related quirk in the 14.04 optimus support, don't really remember the details any more, too painful I guess). I also ended up using bumblebee instead of the NVIDIA's "native" prime-select mechanism, because the performance hit is barely noticeable, it conserves a lot of power in normal operation, and makes major driver upgrades a little bit less risky and/or painful. 

 

But it can be made to work, and when it does, it is actually very stable and has supported the game titles extremely well. The only major issue I've had with any game has been occasional graphical freezing with Bioshock Infininite (here's a blog post to explain the issue and its root cause) and it was mostly resolved with the 'tasksel -c 0,2,4,6 %command%' Steam command line workaround, so even that was not NVIDIA driver related at all.

 

There is another, maybe even bigger reason: actually, that underlined statement above is not entirely true, so I amend it by saying that I've not had any major problems with any released games. My experiences with Shroud of the Avatar (an Unity game engine title) about a year back from now were actually pretty bad, with all kinds of graphical glitches and even occasional crashing. But I hasten to say that 1) this kind of behavior is completely understandable for a game still in early pre-alpha stage of development, and 2) most of those problems were resolved completely when the game switched from Unity 4 to Unity 5 (so now Shroud both works great and looks great).

 

I now investigated NVIDIA driver upgrades, and it looks like the situation with Ubuntu has been improved somewhat, because the Ubuntu devs have kindly decided to support a separate PPA providing the latest NVIDIA binaries.  Previously the best bet for those needing recent proprietary drivers has been the xorg-xedgers PPA, which does not provide the drivers any more, instead directing driver-starved folks to the said "Proprietary GPU Drivers" PPA. However, that very page shows a rather stern looking warning right at the beginning:

 

## ATTENTION STEAM GAMERS:
Valve has reported lots of crashers with `nvidia-358` and the steam client; 
we strongly recommend you use `nvidia-355` until Nvidia publishes new drivers.

 

So this 'nvidia-355' is the current version recommended by Ubuntu developers, at least for Steam gamers, and it is exactly the version I have now, and the version which in practice works very well with all game titles I have (except PoE). I'd be interested if people have actual experience with the most recent version (358.16). 

 

To sum up, based on the above musings, to me the issue is starting to look more and more like a Unity 4 issue than a driver issue. Again it would be nice to know what the "Quality=2" option actually does (what graphics features does it actually enable, compared to "Quality=1").

Share this post


Link to post
Share on other sites
  • 0

I guess the only real way to dig any deeper here is to analyse that core dump - and that's starting to get outside of my sphere of competence ;)

 

Apparently, the core dump will mean there is now a core file sitting in your pillars directory, and you can use gdb to debug it.

 

The first answer here looks like a pretty good outline of how to run it, do a stack trace, and then review individual tasks in the output.

http://stackoverflow.com/questions/5115613/core-dump-file-analysis

 

I have no idea what the output will look like or if it will be intelligible at all. I'll also point out that this is way beyond what a Windows user would be expected to do to troubleshoot this. Debugging is for the devs.

Maybe they could fire up *buntu on a test machine with an nvidia card and see if it's a bug or not.

 

If it was me, I would take this to the *buntu forums.

Edited by haveahappy
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I guess the only real way to dig any deeper here is to analyse that core dump - and that's starting to get outside of my sphere of competence ;)

 

Apparently, the core dump will mean there is now a core file sitting in your pillars directory, and you can use gdb to debug it.

 

The first answer here looks like a pretty good outline of how to run it, do a stack trace, and then review individual tasks in the output.

http://stackoverflow.com/questions/5115613/core-dump-file-analysis

 

I have no idea what the output will look like or if it will be intelligible at all. I'll also point out that this is way beyond what a Windows user would be expected to do to troubleshoot this. Debugging is for the devs.

Maybe they could fire up *buntu on a test machine with an nvidia card and see if it's a bug or not.

 

If it was me, I would take this to the *buntu forums.

 

Yes, I agree. Core dumping is disabled by default in Ubuntu but can be enabled easily. I took a look and it led me to believe that it might be related to how the game handles the bumblebee dual GPU setup, so will have to rule that out first.

 

I'll now do a completely fresh install of the most recent Ubuntu (intended to do so anyway) and test with a fresh install of the most recent drivers, with and without bumblebee. Will be ready enough for testing within a couple of days.

 

If that works, we can conclude it has been related to something in the drivers, and make it a known issue. If it works with the nvidia-prime mechanism but not bumblebee, that can certainly be taken to the Ubuntu forums (and will do so once I have a properly supportable installation).

 

However if it does not work with any of the driver combinations (while all the other games do), I would then conclude it to be a bug in the game itself, or more likely its game engine. Ubuntu forums are probably neither willing nor able to do much about that - only the game devs are.

Share this post


Link to post
Share on other sites
  • 0

Hello,

 

I had the same problem with Pillars of Eternity, not being able to start the game with bumblebee support, getting the error messages as described in post #6.

This happened since I had increased the graphics level to maximum and I could reverse the behaviour by starting the game without bumblebee support, changing the graphics level to medium, and then restarting the game successfully with bumblebee support. Once in the game I readjusted the graphics settings level to high and could play the game.

Of course, that is just a workaround but might come in handy? Besides that I cannot guarantee that changing the graphics settings in the game to "high" without restarting the game are really in place, but the game does not state anything else, e.g. "changes become active after restarting the game".

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hello,

 

I had the same problem with Pillars of Eternity, not being able to start the game with bumblebee support, getting the error messages as described in post #6.

This happened since I had increased the graphics level to maximum and I could reverse the behaviour by starting the game without bumblebee support, changing the graphics level to medium, and then restarting the game successfully with bumblebee support. Once in the game I readjusted the graphics settings level to high and could play the game.

 

Of course, that is just a workaround but might come in handy? Besides that I cannot guarantee that changing the graphics settings in the game to "high" without restarting the game are really in place, but the game does not state anything else, e.g. "changes become active after restarting the game".

 

Thanks for the info, I haven't really had time to be able to look into this further, but it indeed seems to be associated with bumblebee. At least I can confirm that it is not NVIDIA driver version related. So there is a way to reliably replicate the crash in case someone would have time and interest to investigate: simply start the game with the latest proprietary NVIIDA drivers and with bumblebee enabled, and have the graphics set to highest quality.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...