Jump to content
  • 0

[2.02] Potions don't always do something


thelee

Question

Using potions in the midst of combat has always been one of the most frustrating things about combat in pillars, just *waiting* for that critical animation frame to occur before an interruption occurs.

 

But anyway, I don't know if this has always been the case, but I've noticed that sometimes my characters will go through the entire potion quaffing animation but *nothing will happen*. The potion doesn't go away, no buff appears, etc. It will always be a specific potion in a quick item slot; if I try again repeatedly, the character will continue to play out the quaffing animation (provided s/he doesn't get interrupted) and nothing will happen. This does not affect *all* potion/quick item slots. Frequently, I can fail to quaff one potion, and try a different potion/quick item slot and that one will work.

 

Needless to say it's very annoying when this happens with a crucial buff potion I was trying to get before it was irrelevant (like Iron Skins before losing a lot of endurance).

 

EDIT: I can provide a save, but it's very hard to reproduce this consistently. The save would just be a random save I have before a fight.

Edited by thelee
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Sorry for the delayed response.

 

I just had this happen again, and I need to clarify a few things:

 

A. Unlike in my original post, it's not just the slot in question. I just had this happen to my PC, who is a Paladin. I tried quaffing a potion of minor regeneration (slot 3), didn't do anything. I tried quaffing a diferent potion, a potion of wizard' double (slot 1), didn't do anything. Just for fun, I tried quaffing the potion in slot 2 (don't remember what it was), didn't do anything.  So it's not a specific slot, nor is it a specific potion. I can't tell if it's on every character or just a specific character since in this party in question, it's mainly my paladin who is quaffing a lot of potions and using a lot of quick items.

 

B. When the bug occurs, my character does *not* wait for recovery to finish before entering a potion-quaffing animation. Normally when I click on a potion in my quick item slot, I see the icon appear in my combat tooltip, and then when the recovery is finished, my character goes through the drinking animation.  When the bug is triggered however, my character *immediately* begins the potion animation, regardless of where they are at in the recovery. I also don't see the potion icon appear in the combat tooltip. So something is screwed up here.

 

C. Right before the last instance happened, my character was using a scroll of defense, which got interrupted and then caused my character to try again. I don't know if it's anything related, but it is the only thing that I can recall happening before the bug triggered.

 

Since it happened just now, I'll attach the output log. I'll also attach a saved game, though I don't know how reproducible it is so I don't know how useful it is. I will say that if you just walk a bit to the east and south and engage the beetles and just try to win the fight (which will involve drinking several potions), you may trigger the issue.

 

Dropbox folder with output log and save: https://www.dropbox.com/sh/gsgqusoy09ezdwh/AACAAJQMfNWlRU8jULU-8M82a?dl=0

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...