Jump to content
  • 0

Can't leave Fullscreen Mode anymore.


Question

[LINUX -- GOG.com version]

 

I switched my distro to Linux Mint, and afterwards I moved all the necessary files of the game to the file system of Linux Mint, from Xubuntu which I was previously using. I tried current save games and started a new one to test; every time I uncheck Fullscreen in the settings... it will re-apply itself. I've saved the game and completely closed down the game, to the desktop. I re-opened the game, reloaded the save, and checked in the settings and it has Fullscreen rechecked again.

 

I've tried this multiple times, it just keeps re-applying fullscreen. I can't get it to stop doing it.

 

The reason I want to use Windowed Mode is because I get significantly less screen tearing in Windowed Mode than I do in Fullscreen. In Fullscreen it bugs me too much and I can't play the game like that. It's very jarring in Fullscreen mode.

 

How do I force it to never use Fullscreen in Linux, so that it won't be able to re-apply it again? At least until I can fix the screen tearing. I have not yet been able to track down the cause of it. I've tried various monitors, various TVs, various games... and yet it still occurs in everything. I'm thinking maybe it's a graphics card setting, but not sure. Linux uses OpenGL and the nvidia-current software that it uses to configure the graphics card settings is limited on what I can do on Linux compared to Windows or Mac. I do not intend to ever go back to either one of them, so I must find a way to solve my issues here on Linux.

 

I switched to Linux Mint because it's more stable for me, after I've tested on various setups and I was able to use the Synaptic Package Manager more without the system throwing a fit on me for it, which I prefer to use instead of the pre-packaged updates from the Linux Mint team. I like to pick and choose my own thing, as I need it and use the terminal to clean it up. So, the game didn't get worse on me, that's not why I switched. I do still have the problems my previous post states, but the screen tearing doesn't exist on browsers anymore on Linux Mint, but it does in all games. So I have to solve that now and then I'm all set. I placed the XFCE desktop over Linux Mint and removed Cinnamon Desktop because I do not like that. I don't think that would cause any problems, considering it's just another lightweight desktop environment. I just prefer it over Cinnamon.

 

Also, any idea why the game just had to be an archive on Linux from GOG and not an .deb installer or something similar? It just kind of bugs me a little that I can't find the game under Games - I'd have to manually create scripts to make the system think it's an application myself, to make that happen... and I just don't think I should have to do that, for a game that I paid money for. However, it is a minor thing; far minor than the screen tearing, fullscreen>window mode problem and the other issues I've had. Though I did manage to find a way to add the game's launcher to the desktop and put it's own icon to it... finally. It was much harder to do the icon on the desktop thing on Xubuntu and even Netrunner 15 Prometheus (which uses KDE Plasma 5.2 desktop environment). Xubuntu uses XFCE (hints the X--before 'ubuntu'). I just couldn't stand the constant system fits when I tried to run and install packages through Synaptic Package Manager, so I just had to switch - couldn't take it anymore.

 

Ooops... typed way too much. Sorry about that. I have a tendances to enjoy the typing and get carried away sometimes.

Edited by Ram
Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Does anyone know any console comands to force Fullscreen to stay off, or would that require a mod? Since as of right now I cannot get Fullscreen to turn off at all... it just turns itself right back on as soon as I turn it off.

Link to post
Share on other sites
  • 0

Still no luck on this for anyone else I suppose. I still can't do this either. If I could, it'd almost completely remove screen tearing. I don't know why this isn't fixed. It makes no damn sense...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...