Jump to content
  • 0

OS X Black screen on game start


gramathy

Question

Game starts to a black screen with gauntlet cursor. Can't get to main menu, cmd-F doesn't work to flicker the screen to get to options.

 

Player.log indicates it's probably an issue with switching screen resolutions, full log attached:

 

 

 
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
3 data files parsed!
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
--->MatchResolutionToIndex(1920x1200) returning 1
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
--->TryChangeResolutionAndDisplayMode(1, Fullscreen)...
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
--->TryChangeResolutionAndDisplayMode(1, Fullscreen) _currentResolutionIndex is 1, _currentDisplayMode is Unknown
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
--->TryChangeResolutionAndDisplayMode(1, Fullscreen) returning false.  Not initialized.
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
--->ChangeDisplayModeRoutine( Fullscreen, True )...
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
--->ChangeDisplayModeRoutine( Fullscreen, True ) _currentDisplayMode is Unknown
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
--->ChangeDisplayModeRoutine( Fullscreen, True ) calling Screen.fullscreen(true).
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
Switching to 1920x1200 fullscreen
Receiving unhandled NULL exception
Obtained 15 stack frames.
 
Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

My guess is :

- the issue is related to the unity / mono combo : I got the same issue with Dungeon of the endless & Endless legend (was fixed in the first one a few weeks after launch, the second is still affected). Wasteland 2 (no mono AFAIK) was never affected.

- its not multiple monitors alone that triggers this bug. I have only one monitor, but it's wired with HDMI, and if I toggle fullscreen I got the same issue (black screen, audio and cursor, and unity/player.log spammed with unable to find monitor / switching res.

 

Really hope they'll fix this quick, playing windowed is such a pain...

Link to comment
Share on other sites

  • 0

I'm having the same issue. I have a late 2013 15" rMBP with a GeForce GT 750M graphics card, and an external DP-connected display at 2560x1440. Here's what my log looks like:

(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->TryChangeDisplayMode(Windowed)...
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->TryChangeDisplayMode(Windowed) _currentDisplayMode is Fullscreen
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->GetDesktopResolution() returning 2560x1440
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->GetCorrectWindowedDisplayMode() returning Fullscreen
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->TryChangeDisplayMode(Fullscreen) _currentDisplayMode already correct - nothing to do.
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

QuerySomethingChanged() Something changed
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->MatchResolutionToIndex(2560x1440) returning 0
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->TryChangeResolutionAndDisplayMode(0, Windowed)...
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->TryChangeResolutionAndDisplayMode(0, Windowed) _currentResolutionIndex is 0, _currentDisplayMode is Fullscreen
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->TryChangeResolutionAndDisplayMode(0, Windowed) already at desired resolution, only changing display mode.

I got 632KB of log file in just a few seconds of running the game...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...