Jump to content
  • 0
Asmodean-

[Windows 7 x64] Fog of War Problems

Question

Hey,

 

When I was preordering, I was under the impression we had the option to at least force disable the FoW via the console command 'NoFog'. But that's not even a viable option, because it doesn't store the console value with the other settings in the registry.

 

It defaults back to a (bugged) version of the Fog every time you: load your save, enter/exit buldings, enter/exit too or from areas, etc. Basically anytime you do anything requiring a map load. So it's quite useless.

 

I would love some Fog of War specific options. I mean, to enable, or disable it properly, without uncovering the whole area map before it's discovered. Or even to adjust the start radius of the fog, so it begins outside of your screenspace view. Or, even only use Fog on areas that have not been discovered yet?.

 

I'm not trying to cheat, I just want to be able to admire the nice scenery. Apparently, being able to see more than a couple of metres is cheating, yet fast mode 24/7 is not?.

 

Any help is appreciated, thank you/

  • Like 1

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I don't suppose anyone has any input on this?. The FoW on my save file is stuck like below. With seemly no way of resolving it. Other than deleting my save file and starting again.

 

Thought I'd post this before going to bed, just in case.

 

Sb1q908.jpg

Share this post


Link to post
Share on other sites
  • 0

Having same issue


"Very well permit me on this night. To break your hearts once more. This is the story of the Chain of Dogs. Of Coltaine of the Crow Clan, newly come fist to the 7th Army"- Duiker:Memories of Ice

Share this post


Link to post
Share on other sites
  • 0

So, I said I'd check back in on the game, and reinstalled it again today. Almost a year later, and this issue still persists..

 

I'm sorry if this comes off rude. But how difficult can it be to resolve a single command.  Of which, hasn't been working since early beta, before the game was even initially released.

 

The NoFog bug has been reported many times since then (I've checked). And still nothing has been done about it.

 

You clearly created the command for showing off screenshots, and footage of the game pre-release. @Josh Sawyer even responded to my preorder question, personally in a livestream. About being able to use the console to disable the fog, for people who like to just play it as an rpg.

 

But, you didn't bother to actually make it usable, because you didn't need it yourselves for the "pretty demo screenshots".

 

Blatant disregard for player preferences. Not to mention lying during preorders. (Yes, at this stage it's a flat-out lie).  it was one thing just after the game released, but a year later... Simply disappointed at this stage, Obsidian.

Edited by Asmodean-

Share this post


Link to post
Share on other sites
  • 0

Hey Asmodean-,

 

Using NoFog in the console is a cheat command and not really a bug with the game itself. If you already used NoFog and you load into an area that has the issue in your screenshot, just use the command again and it will clear the fog around your characters.

 

Thanks!


Whats this at obsidian.net?

Share this post


Link to post
Share on other sites
  • 0

Hey Asmodean-,

 

Using NoFog in the console is a cheat command and not really a bug with the game itself. If you already used NoFog and you load into an area that has the issue in your screenshot, just use the command again and it will clear the fog around your characters.

 

Thanks!

 

Hey Aarik D,

 

Thanks for replying.

 

So, if I've got this straight here: this is not classified as a bug(?). Even though, for all intensive purposes the command which you supplied to your players, is literally useless other than for taking screenshots?. Quite a few people asked prior to the game releasing "are we able to disable to fog, to play the game without it", and the response was "yes, we have a (cheat) console command for removing the fog".

 

You guys kind of omitted the fact that the NoFog command simply doesn't work. Fobbing it off to "well....it's a cheat, so it's not really a bug" is bs, and you know it. It not only re-enables the FoW everytime you enter or exit anywhere that requires a loading screen (which is basically everywhere). It also switches to a bugged version (as shown above) to where the party fog is re-enabled.

 

To make this even remotely usable, you have to literally re-enter the command everytime you walk into, and out of a building. Which is ridiculous. Do want to estimate how many buildings you'd enter/exit during a playthrough of PoE?.

 

Simply put - if you didn't want people to be able to disable the fog, you should have stated so prior to release (when asked), and also not provided the command at all. Instead of providing them with a practically useless, broken command. Which only teases them.

 

You'd think I was requesting something completely ridiculous. I'm only asking that you fix the command, so that it saves it in the registry along with the settings. So when you've got it enabled. It stays so.

 

-----------------------------------------------------------------------------------------------

Some people were looking forward to playing the game as an rpg, and being allowed to enjoy the artwork done for the areas, etc. I have zero interest in cheating. I simply would like to see the game I'm playing. Or at least have the option to, given I actually wouldn't have bought the game, if you had stated you in fact cannot really remove the fog (because I, personally really dislike persistent FoWs that follow you around, even after uncovering the areas). It's not about the money, it's about the disappointment.

 

Edit: Gotta say, I'm disappointed. Well firstly that it took 10+ months for a reply, and secondly that you're trying to fob off a genuine issue, because it's a minority. I've been a fan of you guys since KOTOR II..

Edited by Asmodean-

Share this post


Link to post
Share on other sites
  • 0

Hey Asmodean,

 

I apologize for the inconvenience, but the console command is not begin supported. I understand your feelings towards fixing the issue, however this would not be an easy fix. Its not that its a low priority or a minor issue, it would require a great deal of work to actually fix it. It is not ideal, but the work around for now is keep using the console command. A quicker way to do this is to press the UP Arrow which will recall your last entry in the console command. 

 

Having a No Fog of War option is something we’ll keep as a suggestion in our database for future updates, but we can’t promise it will be put in at this point in time.

 

Thank you for your understanding and we appreciate your feedback.


Whats this at obsidian.net?

Share this post


Link to post
Share on other sites
  • 0

Hey Asmodean,

 

I apologize for the inconvenience, but the console command is not begin supported. I understand your feelings towards fixing the issue, however this would not be an easy fix. Its not that its a low priority or a minor issue, it would require a great deal of work to actually fix it. It is not ideal, but the work around for now is keep using the console command. A quicker way to do this is to press the UP Arrow which will recall your last entry in the console command. 

 

Having a No Fog of War option is something we’ll keep as a suggestion in our database for future updates, but we can’t promise it will be put in at this point in time.

 

Thank you for your understanding and we appreciate your feedback.

 

Well, at least you were straight up with me this time. I appreciated it.

 

I'd imagine the problem lies somewhere in how your maps are cached/loaded?. Just a final suggestion on the matter. You may want to look into a conditional check to see if the console command is triggered, and if so refresh the NoFog command on reload. We had a 'somewhat' similar problem with the msaa not sticking when the game initially launched.

 

I also appreciate you taking my feedback into consideration, cheers.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...