Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

abortion / snuke europe problem

  • Please log in to reply
1 reply to this topic



    (0) Nub

  • Initiates
  • 1 posts

Hi Guys,


Up until last night, I thought this was the best game of the year... bravo, amazing job... but then I came to the snuke disarm mission, and it's became beyond frustrating... When I say I've attempted to disarm it 50 times is an understatement. My wife threaten to take my xbox away if I didn't relax :-D


Let me first say im in the EU, so answer like "Just do it like you did the abortion missions" don't help at all, because they are censored.


I stick the stupid needle in without issues. I start spinning the L stick COUNTER clockwise, I've tried slow, ive tried fast, always as consistent as possible and it always ends the same. "Is that my oil?" and then BOOM, bomb.


Appreciate any and all advice...


From what I've seen on Facebook, alot of EU people are having a problem with this :-/









    Forum Moderator

  • Moderators
  • 5212 posts
  • Location:Fawcett City
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer
  • Lords of the Eastern Reach Backer
  • Deadfire Backer
  • Fig Backer
I can't really help you; I did it fast and just continued spinning the L stick until that part of the sequence finishes but I have the uncensored version - I hope this isn't a problem created by the censoring!

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users