Jump to content
  • 0
Sign in to follow this  
Dallen

Entire Game Has Yellow Tint

Question

I just got the game and i'm able to play just fine. The only problem is that the entire game has an awful yellow tint to it.

 

Any help making it go away?

post-96296-0-31380800-1394081612_thumb.jpg

Share this post


Link to post
Share on other sites

19 answers to this question

Recommended Posts

  • 0

Are you on PS3, 360, or PC?

 

Have you tried running the game in Windowed mode if you're on PC?

See if that makes the tint go away.

 

Do any of your other games have this issue?

Edited by Bazgrim

Share this post


Link to post
Share on other sites
  • 0

This is on PC. I have it purchased via Steam.

 

It does not change between windowed mode and fullscreen.

 

No other games have this issue. I booted up Portal to make sure, and it ran without a problem.

Share this post


Link to post
Share on other sites
  • 0

Do me a favor and go to Documents\My Games\South Park - The Stick of Truth

Open up your user.ini file in notepad and post the contents here.

Also go into C:\Program Files (x86)\Steam\SteamApps\common\South Park - The Stick of Truth

Find config.ini, open it with notepad and post the contents here.

Please encase both of them in their own code tags on the forum.

[code][/code]

Share this post


Link to post
Share on other sites
  • 0

I just got the game and i'm able to play just fine. The only problem is that the entire game has an awful yellow tint to it.

 

Any help making it go away?

 

 

 

Do me a favor and go to Documents\My Games\South Park - The Stick of Truth

Open up your user.ini file in notepad and post the contents here.

Also go into C:\Program Files (x86)\Steam\SteamApps\common\South Park - The Stick of Truth

Find config.ini, open it with notepad and post the contents here.

Please encase both of them in their own code tags on the forum.

[code][/code]

 

This may be an issue with corrupted data / settings. The least effort fix for this would probably be to reinstall the game if you have not tried that already. 

 

Right click on the game in your library ->click delete local content -> click install again

 

If this does not resolve your issue, please post the specs of your computer (run -> dxdiag and post the CPU, memory, and graphics card) and the contents of the ini file mentioned above. 


https://twitter.com/IridiumGameDev

Ex-Obsidian Senior Programmer

Share this post


Link to post
Share on other sites
  • 0

user.ini:

 

 

[Engine.Render]
adapter = -1
anisotropic = 1
default_brightness = 0.138000
default_contrast = 0.946001
default_contrast_range_low = 0.09
default_display_conversion = box
default_gamma = 1.0
dist_fade_duration = 0.5
dist_fade_in_range = 40.0
dist_fade_out_range = 45.0
effects_quality = 1
enable_antialias = false
enable_bloom = false
enable_color_controls = false
enable_color_correction = false
enable_depth_of_field = false
enable_fog = false
enable_heat_haze = true
enable_postprocess = true
enable_transparent_depth = false
full_screen = 0
full_screen_height = 0
full_screen_width = 0
motion_blur_enable = 0
motion_blur_max_length = 0.3
motion_blur_scale = 0.5
movie_sharpen_amount = 0.0
movie_sharpen_radius = 0.0
msaa = 0
s3d_ar_multiplier = 1.3
scaleform_edge_aa = 1.0
separate_dimensions = 1
shader_quality = 1
shadow_quality = 3
support_aspect_ratio_16_10 = false
support_aspect_ratio_4_3 = false
support_aspect_ratio_custom = false
support_skinning = false
texture_quality = 4096
use_directx_11 = false
vsync = 1
window_height = 900
window_width = 1440

[Engine.Audio]
enable_communication = 1
enabled = 1

[Engine.Perf]
perf_marker_categories_enabled = 0

 

config.ini:

 

 

; Application override configuration file

[Engine.Render]
default_gamma            = 1.0
full_screen            = 1
shadow_quality            = 3
support_aspect_ratio_4_3    = false
support_aspect_ratio_16_10    = false
support_aspect_ratio_custom    = false
use_directx_11            = false
separate_dimensions        = 1
support_skinning        = false

; render post-process settings
enable_postprocess                      = true
enable_depth_of_field                   = false
enable_bloom                            = false
enable_antialias                        = false
enable_color_correction                 = false
enable_color_controls            = false
enable_fog                = false
enable_heat_haze                        = true
enable_transparent_depth         = false
motion_blur_enable                      = false
motion_blur_scale                       = 0.5
motion_blur_max_length                  = 0.3
movie_sharpen_amount            = 0.0
movie_sharpen_radius            = 0.0
scaleform_edge_aa                       = 1.0

[Engine.Perf]
; perf_marker_categories_enabled is a bit field. The value defs
; are in oei_perf_marker.h.
; PERF_MARKER_CATEGORY_RENDER = 0x00000001;
; PERF_MARKER_CATEGORY_GAME    =   0x00000002;
perf_marker_categories_enabled = 0
log_disc_access = false

[Game.Default]
project_name            = South Park - The Stick of Truth
demo_mode            = false
disable_warnings    = false

[Game.Audio]
listener_offset = 8.0
listener_separation = 16.0

[Game.Mouse]
clip_to_screen        = false
use_hardware_mouse    = true

[Game.GUI]
curve_tolerance            = 3.0
collinearity_tolerance        = 3.0
skip_single_node    = false

 

Thanks

Share this post


Link to post
Share on other sites
  • 0

user.ini:

[Engine.Render]
adapter = -1
anisotropic = 1
default_brightness = 0.138000
default_contrast = 0.946001
default_contrast_range_low = 0.09
default_display_conversion = box
default_gamma = 1.0
dist_fade_duration = 0.5
dist_fade_in_range = 40.0
dist_fade_out_range = 45.0
effects_quality = 1
enable_antialias = false
enable_bloom = false
enable_color_controls = false
enable_color_correction = false
enable_depth_of_field = false
enable_fog = false
enable_heat_haze = true
enable_postprocess = true
enable_transparent_depth = false
full_screen = 0
full_screen_height = 0
full_screen_width = 0
motion_blur_enable = 0
motion_blur_max_length = 0.3
motion_blur_scale = 0.5
movie_sharpen_amount = 0.0
movie_sharpen_radius = 0.0
msaa = 0
s3d_ar_multiplier = 1.3
scaleform_edge_aa = 1.0
separate_dimensions = 1
shader_quality = 1
shadow_quality = 3
support_aspect_ratio_16_10 = false
support_aspect_ratio_4_3 = false
support_aspect_ratio_custom = false
support_skinning = false
texture_quality = 4096
use_directx_11 = false
vsync = 1
window_height = 900
window_width = 1440

[Engine.Audio]
enable_communication = 1
enabled = 1

[Engine.Perf]
perf_marker_categories_enabled = 0

config.ini:

; Application override configuration file

[Engine.Render]
default_gamma            = 1.0
full_screen            = 1
shadow_quality            = 3
support_aspect_ratio_4_3    = false
support_aspect_ratio_16_10    = false
support_aspect_ratio_custom    = false
use_directx_11            = false
separate_dimensions        = 1
support_skinning        = false

; render post-process settings
enable_postprocess                      = true
enable_depth_of_field                   = false
enable_bloom                            = false
enable_antialias                        = false
enable_color_correction                 = false
enable_color_controls            = false
enable_fog                = false
enable_heat_haze                        = true
enable_transparent_depth         = false
motion_blur_enable                      = false
motion_blur_scale                       = 0.5
motion_blur_max_length                  = 0.3
movie_sharpen_amount            = 0.0
movie_sharpen_radius            = 0.0
scaleform_edge_aa                       = 1.0

[Engine.Perf]
; perf_marker_categories_enabled is a bit field. The value defs
; are in oei_perf_marker.h.
; PERF_MARKER_CATEGORY_RENDER = 0x00000001;
; PERF_MARKER_CATEGORY_GAME    =   0x00000002;
perf_marker_categories_enabled = 0
log_disc_access = false

[Game.Default]
project_name            = South Park - The Stick of Truth
demo_mode            = false
disable_warnings    = false

[Game.Audio]
listener_offset = 8.0
listener_separation = 16.0

[Game.Mouse]
clip_to_screen        = false
use_hardware_mouse    = true

[Game.GUI]
curve_tolerance            = 3.0
collinearity_tolerance        = 3.0
skip_single_node    = false

Thanks

 

Did you try verifying your steam data or reinstalling the game?

Can you post dxdiag info?


https://twitter.com/IridiumGameDev

Ex-Obsidian Senior Programmer

Share this post


Link to post
Share on other sites
  • 0

I'm in the process of doing that now. I actually posted that last bit before you requested it. I just have less than five posts so I have to wait for moderator approval. dxdiag.info is incoming.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Reinstalling did not fix the issue.

 

Here is the dxdiag info:

 

Processor: 2.66GHz Intel Core i7 M620

Memory: 8GB 1067 MHz DDR3

Graphics Card: Nvidia GeForce GT 330M 512MB

Share this post


Link to post
Share on other sites
  • 0

Do you use any custom ICC/Color profiles?

Hit your start orb, type in "Advanced Color Management" without quotes.

Click the first option "Change advanced color management settings..."

Click the Advanced tab.

Make sure everything is set to System default.

Each drop down list should say "System Default(someinformationhere)"

If not, change it to the system default.

Share this post


Link to post
Share on other sites
  • 0

Reinstalling did not fix the issue.

 

Here is the dxdiag info:

 

Processor: 2.66GHz Intel Core i7 M620

Memory: 8GB 1067 MHz DDR3

Graphics Card: Nvidia GeForce GT 330M 512MB

 

 

FYI, I'm seeing this too when I try to run it in a VMWare Fusion instance on a Macbook Pro.

 

What version of windows are both of you running? If windows 8, try running the game in compatibility mode for win7. 

 

Attaching DXDiag txt might help because it will have additional information.


https://twitter.com/IridiumGameDev

Ex-Obsidian Senior Programmer

Share this post


Link to post
Share on other sites
  • 0

I was using Windows 8. I just went in and tried to do it in compatibility mode for WIndows 7. I did this by going into the steam folder for the game and setting the exe to run in compatibility mode. This did not change it. I also tried it on Vista and XP.

 

When I saw pitched_black mention he also had the same problem on a Macbook Pro in VMware, I went off to set up a bootcamp partition to try a sanity check its really limited to VMware Fusion. The first attempt at installing it via Bootcamp was producing an odd error ("App already running" on my first launch attempt). I'm redownloading it on the bootcamp partition now while I'm typing this.

 

I'll try to get you two more information when my class ends, such as attaching DXDiag txt.

 

@Bazgrim: I couldn't find Advanced Color Management on Windows 8. I went into start and also tried searching for "color" without the quotes. It didn't bring up any results.

Edited by Dallen

Share this post


Link to post
Share on other sites
  • 0

I have a Windows 7 instance so it's probably specific to the vmware fake-graphics device and not the OS or settings. The Macbook I found this on has the Intel Iris Pro and Nvidia GeForce GT 750 M chips.

 

Do you still want a dxdiag file now that we know how to reproduce this?

Share this post


Link to post
Share on other sites
  • 0

For color management on windows 8, type in colorcpl in the search bar.

If that doesn't work, search for Run, open it and type colorcpl in there and hit enter.

Share this post


Link to post
Share on other sites
  • 0

if it's a vmware specific issue, you're going to have to contact vmware for support. I'd recommend booting into an actual windows installation through something like bootcamp. 


https://twitter.com/IridiumGameDev

Ex-Obsidian Senior Programmer

Share this post


Link to post
Share on other sites
  • 0

I have a workaround!

 

Grab the gfxCardStatus tool from http://gfx.io/ and set the macbook to Integrated-Graphics Only. This has to be done while the Windows VM is powered down. Boot up the VM, boot up the game, and, no yellow tint.

 

That worked beautifully. Running in Windows 8.1 VMWare Fusion as well. At first thought it was f.lux, and then thought it was just me. Thanks for a great workaround - nice find! I have to go poop now.

 

Also, just created a forums account solely to post this reply; thanks Obsidian for allowing mailinator email addresses. Cheers.

Share this post


Link to post
Share on other sites
  • 0

I'm experiencing this exact same problem, running on a Parallels Desktop virtual machine.

Problem being, that gfxCardStatus utility doesn't work on my iMac (I also tried the Color Management tip above).

 

Any ideas? I'm stumped. Thank you.

Share this post


Link to post
Share on other sites
  • 0

I'm running this game through a steam install on Windows 8.1 via vmWare Fustion 7 Pro on an iMac.  I get the same yellow tint in the game.  Anyone find a solution to this yet?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...