Jump to content

System compatibility


Recommended Posts

Ive recently repurchased KOTOR II and it will not play past the opening cinematic.

I have played around with the compatibility settings to no avail(currently running windows 7)

ive tried running it in windows 2000, ME, and windows 98 compatibility mode.

Maybe im just retarted.

 

If anyone could shed some light on this situation for me it would be much appreciated since it is one of my all time favorite rpgs.

Link to comment
Share on other sites

Unfortunately, the game engine did not age well. A number of issues I can remember is that it needs workarounds form anything running more than single core, it doesn't like Vista/7 (the Miles Sound System driver doesn't work) and a number of strange picky habits with gfx cards. Each individual issue having separate workaround or fixes. Some issues may not be fixable.

 

This place may have the answer to one of the issues

 

Besides that and checking the stickied FAQ thread, I'm afraid I don't have too many suggestions.

“He who joyfully marches to music in rank and file has already earned my contempt. He has been given a large brain by mistake, since for him the spinal cord would surely suffice.” - Albert Einstein

Link to comment
Share on other sites

  • 1 month later...

I have heard that everyone with a more recent computer has this difficulty. I own a new computer, with:

OS: Windows 7 Home Premium

Manufacturer: HP

Processor: AMD Phenom X6 1065T

2.90 GHz

Installed memory/ RAM: 8 GB

64-bit OS

1 TB memory

The only programs I have installed are those that came with the computer; useful programs (like flash players, visual software, etc.); and other games.

I won't bother looking at what I have the game settings configured to. If that's an issue, someone's probably tested all possible fixes with that anyway.

 

And the first time I installed it, it worked perfectly. On someone else's (also new) laptop, it could not get past the character generation, as everyone is saying - only then did I actually learn that it is supposed to not work on more advanced computers. Now I've almost beaten the game, with only 1 concern: the game occasionally crashes. The cause of the crash is identified by Windows as being another program. It's called something related to the game - it's not outside interference from some other program. I close the program through Task Manager, and it's like nothing has happened. The first game had a similar problem, but I can't really remember. And it never crashed frequently enough to be an issue - only very rarely.

 

I hope this info helps other people figure out a better, universal cure (my friend's game could not be fixed even with the suggestions on the LucasArts website, and it was nothing to do with the game copy itself). This probably won't end up making a difference anyway, but there's a small chance this can help people figure out the cause of the problem.

Edited by Myceira
Link to comment
Share on other sites

Ugh.. It looks rather complicated to make it work on Win7. Probably much easier to just install WinXP, maybe set-up as a dual-boot option..

 

Not really helpful, but just striking out dual-cores as a culprit. Even though my system is not exactly recent only the OS makes it really really old and the game runs flaw.. erm.. -fully out of the box, patched-up.

 

(OS: Windows XP)

CPU: Core 2 Duo E6600 @ 3.0GHz

Video: ATi HD Radeon 4850

Audio: Creative X-Fi

 

The Configure option from the launcher has a few debugging options and the scan itself might point to some obvious hotspots.

 

The Configure->Scan Hardware:Details complains that I do not meet the recommended requirements for the Video. Kinda makes sense as a ATi Radeon 4850 is obviously an inferior card to a ATi Radeon 9200.. (namingschemes, blargh) But apart from that there are no other highlights or graphics issues.. other than I can easily run it 8x AA.

 

Only issue is that sometimes the move buttons (forward & backwards) doesn't respond for awhile after combat even though everything else works - until it crashes.

 

Don't forget to patch it up: http://www.lucasarts.com/support/update/kotor2int.html

(Signatures: disabled) 

Link to comment
Share on other sites

It's not a simple matter of age or OS, it runs fine for me, that is on a recent AMD E-350 dual-core netbook, 4GB Windows 7, 32 bit. I did nothing special to make it run.

 

It is not flawless though, in particular with movies enabled there's lots of screen-switching and blanking and I experience 'weird' behaviour, that is, black screens and loss of input-focus, which can usually be bypassed with ALT-TABbing and task-switching around. But I can ALT-TAB freely, which, iirc, wasn't the case under W2K - and I can run it as user rather then Admin, without doing anything to make that work.

 

I'd try updating drivers, disabling movies, that sort of thing. Let the config-tool set it up and then later tweak the settings.

Edited by MalaksBane
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...