Jump to content
  • 0
tollie69

Dungeon Siege 3 Multiplayer Connection Problems

Question

Hi

 

Can some one please explain to me if its someting ime doing wrong or is steam or the game it self!

 

I just cant join any multiplayer games private or online if i search for games i pick them up , but cant join it just loads and loads forever!

 

Me and my freinds have tried to play together for a while now and they cant seem to join any games either i have hosted they have hosted no one can join the other.

 

I get no error messages it just loads forever left it for more then and hour once!

 

I am pretty sure its got nothing to do with my internet, router or firewalls because every other game i have plays fine online, except if DS3 needs specific ports to be open googled it , but cant find any info on that.

 

I also doubt it my computer i have and i7- 870 , p55-gd65 mobo , 4gig ddr3 2200 gaming ram and a 460gtx hawk 1gig gpu! so i no its nit computer specs!

 

Any help would be apreciated want to play the game online very badley.

 

Thanks

 

Dean

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

When you are in game (being in menu is enough) have they invited you to join the game? Did you click yes on the invite?


Hate the living, love the dead.

Share this post


Link to post
Share on other sites
  • 0
When you are in game (being in menu is enough) have they invited you to join the game? Did you click yes on the invite?

 

 

 

Yes we have tried it they send me a invite i accept it and it just starts to load but never stops! its not like ds3 crashed the game is stil fine it just loaaaddds and never stops no errors nothing.

 

The SP is fine so i dont think there is something wrong with my game!

Share this post


Link to post
Share on other sites
  • 0
I am pretty sure its got nothing to do with my internet, router or firewalls because every other game i have plays fine online, except if DS3 needs specific ports to be open googled it , but cant find any info on that.

 

Have you attempted to forward all ports, just to check? Usually there's a DMZ option that does that in the router setup. I'd say test that, just to rule out the router blocking the ports it needs. I had connection issues the first day, which opening all ports fixed, then it started working without opening all or even specific ports a day or two later for no apparent reason.


I'm going to need better directions than "the secret lair."

 

-==(UDIC)==-

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...