Jump to content
  • 0
SirMoogie

Voice Echos in Multiplayer (PC, non-local)

Question

When playing in multiplayer networked the character and NPC voices produce an echo. It is as if the game is registering the voice events from the other PCs connected and having my PC replay the sounds. This produces an awful playing experience where the characters will repeat what they've said shortly after just saying it (sometimes softer). This problem is not unique to my setup. I play with two others who have different set ups and they have the same problem. We play through Steam.

Edited by SirMoogie

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
When playing in multiplayer networked the character and NPC voices produce an echo. It is as if the game is registering the voice events from the other PCs connected and having my PC replay the sounds. This produces an awful playing experience where the characters will repeat what they've said shortly after just saying it (sometimes softer). This problem is not unique to my setup. I play with two others who have different set ups and they have the same problem. We play through Steam.

 

I'm not sure if I can help with this problem without sounding sarcastic, but I'll try. One solution should be to get your friends and yourself to turn off the speakers and use a pair of headphones. Problem should be solved after that. Otherwise, you and your friends will have to adjust your speaker volume and positioning relative to your mic and hope for the best. Maybe check your sound settings to see if there's some echo cancellation available that might also reduce it.


I'm going to need better directions than "the secret lair."

 

-==(UDIC)==-

Share this post


Link to post
Share on other sites
  • 0
When playing in multiplayer networked the character and NPC voices produce an echo. It is as if the game is registering the voice events from the other PCs connected and having my PC replay the sounds. This produces an awful playing experience where the characters will repeat what they've said shortly after just saying it (sometimes softer). This problem is not unique to my setup. I play with two others who have different set ups and they have the same problem. We play through Steam.

 

I'm not sure if I can help with this problem without sounding sarcastic, but I'll try. One solution should be to get your friends and yourself to turn off the speakers and use a pair of headphones. Problem should be solved after that. Otherwise, you and your friends will have to adjust your speaker volume and positioning relative to your mic and hope for the best. Maybe check your sound settings to see if there's some echo cancellation available that might also reduce it.

 

Oh, silly, if that were the problem we'd have tried that. We are not in the same room, let alone the same house. The echoed voices are definitively coming from my machine. None of us are using microphones to communicate. We use text based communication.

Edited by SirMoogie

Share this post


Link to post
Share on other sites
  • 0

I Guess it the same thing as happened to me before Steam see your Sound card output as a microphone input if so do this should fix it.

 

Go into steam view setting and change the voice "when voice chat is active" from when ever I speak to "Use Key to transmit" and leave as none or change it to some key you need move.

Share this post


Link to post
Share on other sites
  • 0
I Guess it the same thing as happened to me before Steam see your Sound card output as a microphone input if so do this should fix it.

 

Go into steam view setting and change the voice "when voice chat is active" from when ever I speak to "Use Key to transmit" and leave as none or change it to some key you need move.

 

Thanks this fixed our problem. :shifty:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...