Jump to content
  • 0
Sign in to follow this  
Dizz

InGame Static sound?

Question

Okay, so when i played the demo. I got sound and that, but when i played the full game when i bought it. The game keeps making my sound and voice give static like you hear a static interfering with the sound. My friend told me my microphone was giving a static sounding when ever i talked. I did fresh updates to Graphics card and on board sound.

I got a 3GB Graphics card that is well enough getting really nice fps but i cant seem to play it without it sounding like static is killing it. Also my windows updates are up to date, flash direct x are up to date.

Could i get some help please? Would like to play without it giving static through my speakers or headphones an then the sound going out and making me have to reboot.

 

Also on a side note, i notice whenever i get near water it seems to want to start that static effect or something environmental happens like tree's blowing leaves or something.

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Bump once more in hope to actually PLAY the game.

 

Actually forgot to say that its on my pc an not ps3 or 360.

Edited by Dizz

Share this post


Link to post
Share on other sites
  • 0

Posting more info on your setup would most likely help. Windows version, your motherboard, sound card etc....

Have you tried muting the microphone completely in game and using ventrilo/teamspeak/skype instead of it?


Hate the living, love the dead.

Share this post


Link to post
Share on other sites
  • 0

I can try that.

Mobo: ASUS Crosshair IV Formula

Sound: Onboard

OS: Windows 7 Ult x64 Bit Service pack 1

How do i go about muting my microphone ingame?

Share this post


Link to post
Share on other sites
  • 0

...Taking it out?

 

Edit: Disabling the option on Steam should do it as well. I believe Dungeon Siege 3 uses whatever Steam has for VoIP

Edited by Chasted

Share this post


Link to post
Share on other sites
  • 0

Didn't help at all no offense, tried em both just now an still being pretty much unplayable.

Share this post


Link to post
Share on other sites
  • 0

I take it you have tried headphones and managed to get the same effect well uh...

 

Have you tried turning down the volume of the effects in the volume tab? It isn't the best fix but if that is causing the problems.

 

Edit: Might sound like a strange addition but Mass Effect 1 had a similar issue (A little more wide-spread... And it sounded like a Vacuum Cleaner while using the land rover) and to fix it you had to reduce the amount of available audio channels the game can use (I'll be damned if I knew how to do that, however)

Edited by Chasted

Share this post


Link to post
Share on other sites
  • 0

I'll give that a try but i had lowered the graphics and unplugged my mic and headset and was already using a headset too.

Could hear it more with a headset than you did with speakers

It just staticy really bad along like crackles. After a while my sound goes out an you cant hear anything i mean anything even when i leave the game an programs dont function right so i have to reboot.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...