Jump to content

Please Postpone Game - Controls Horrible


Recommended Posts

Being a huge Dungeon Siege I & II fan I just had to go through with the registration process to let you know that you guys are doing it all wrong!

 

The graphics are great! Good Job on that! Outstanding, actually.

 

However, two major flaws in the game that I can guarantee will make this game a flop and have all the gaming sites reviewing you with low scores is this:

 

1) Most Important - Your controls are absolutely horrible. I dont want to constantly have to correct the auto camera angle for every single corner I take. This REALLY handicaps the gameplay 100% It becomes more of a chore than a game after a few minutes.

 

2) Your hack and slash sound effects are totally weak sounding...When you attack any mob in the game with a sword or a staff it sounds as if the actual *slash noise* of your characters weapon is muffled under either a pillow or underwater.

It doesnt make the gamer feel as if he is actually slashing anything..Its not very fulfilling at all.

 

With these two major flaws aside, I could probably get into the actual storyline and game.

 

I am sure if your team were to postpone this a few months and work on these flaws, your game would sell a hundred times better.

If you guys dismiss this and push the game out without looking into these flaws...mark my words when I say it will be a flop.

 

Gamers like to read reviews on gaming websites and I am 100% sure all websites will comment on how horrible the controls are.

 

Hope you folks do the right thing.

Edited by merx
Link to comment
Share on other sites

1) Most Important - Your controls are absolutely horrible. I dont want to constantly have to correct the auto camera angle for every single corner I take. This REALLY handicaps the gameplay 100% It becomes more of a chore than a game after a few minutes.

 

You can turn that off in the options, camera auto-orient.

Link to comment
Share on other sites

Tried that. When scrolling right or left it still auto zooms in way too close and you need to manually correct it.

 

I just tested this and it is not doing this on my machine. I did notice that I turned this off from the main menu and then started a new game and it was turned on so I had to disable it again. There is absolutely no auto-camera movement once this is disabled correctly.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...