Jump to content

Booted to Main Menu at Dxun 2nd time


Recommended Posts

So, like many others I am having a freezing/booting problem. I've gone through and played through all worlds one time, except Korriban. Now, I have gone back and made sure I can travel anywhere at this point.

 

However, after hitting Korriban, and reentering the hawk, seeing T3's message and G0T0 killing Bao-Dur's Remote (sorry if that's a spoiler to anyone), I try to go to ANY world (not just Dxun where I want to go), and once the cutscenes are over, I get kicked out to the main menu (I don't get to do anything, the last thing I do is click on the TRAVEL button to go back to Dxun).

 

At that point, I can't click on anything before I hit Alt-F4 and click cancel, then I can access the main menu. I've tried reinstalling and going back to Dxun (the last world I visited before Korriban), the going through Korriabn again (and finishing various parts of it, or none at all), but the same thing still happens. This seems independent of the game version I use (1.0 or 1.0b). I have tried varrying the graphics level and turning off the movies as well, but to no avail. I have reinstalled several times and that doesn't seem to work either.

 

Here are the specs that KOTOR2 spits out:

 

Win XP SP1

AMD Athlon XP 1492 Mhz (a little slow)

512 MB RAM

HD1: C: (where Windows is) 177GB free

HD2: F: (where KOTOR2 is) 144 GB free

Video: Radeon 9600 Series 256MB

Audio: NVIDIA® nForce Audio Codec Interface (on the Mobo)

OpenGL: ATI Tech Inc. 4.4.4063 WinXP Release

DirectX: 9.0c

 

 

Any help would be appreciated. I want to finish this game.

 

OGOPTIMUS

Link to comment
Share on other sites

Well, after searching around for some soultions I just tried warping to Dxun (cheat). And that worked wonderfully, I got to play again, and all was fine. Until after I met with the Jedi on Dantooine (had to warp there too).

 

I got stuck going back to Telos after Keria and Handmaiden-the game would try and autosave there (no matter if I turned it on or off) and it froze about 1/3 of the way through saving. So I moved all my savegames out to another folder except the one right before going to Telos and I alt-TAB'ed out of the game to delete the 261TEL and 262TEL files from the "gameinprogress" directory. At the same time I also moved the WNASPI32.DLL file out of its current directory. And lo and behold, everything worked. Now I'm not sure which of these things actually did the job (however, moving the file alone did not work). At the moment the game is still open on another computer (not turning it off while I've actually got it working finally). So this seems like a good fix.

 

OGOPTIMUS

Link to comment
Share on other sites

If the game crashs it does not delete the last games in progress stuff. Which leaving that there can confuse it. Best thing to do after a crash is to load then exit and load again. That will delete the unused entries in those folders confuseing it. I've tried just deleteing the folders them selves: Gameinprogress, currentgame, temp. But there seems to be something else also created while a game is loaded.

Link to comment
Share on other sites

  • 4 weeks later...

I found the solution to this problem after the game skipped to main menu after many hours of playing(when trying to leave the EH). This bug drove me nuts so i decided to find a way to get around it!

 

!Caution!

Before attempting this fix, make a backup of your savefiles in a safe place!

 

If that is ok with u..proceed! :-

 

Here is what u have to do to resolve this problem:

 

1. Start the game and load your favourite saved game (note the save number).

2. Press Alt+Tab to switch to desktop

3. Find the "gameinprogress" and "currentgame" folders.

4. Remove the .sav files that are the source of your headache, i.e. the .sav that has a name similar to the module(map) that fails to load. For example if you cant get to Dantooine u should look for xxxDAN.sav and remove it.

5. Now also remove the files "savenfo.res" & "SAVEGAME.sav" from the folder that contains the savegame you're currently running.

6. Press Alt+Tab to go back in game.

7. Go to save menu and save this game on the savegame now called "Old Save Game"

with the designation 0.

8. Once the game is saved u choose to exit, quiting the game.

9. Start it up again and load the "Old save Game" save.

10. Good luck and have fun!

 

This is an "AS IS" guide, dunno if it will really help u but i did it for me!

Any feedback on however it worked is appreciated.

 

Cheers!

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...