Jump to content

Texture Colour Distortion.


Recommended Posts

Right well, i've been meaning to post this for a while now, but never got around to it, so here it is. When playing KOTOR2, i often see textures which are distorted colour-wise. For example, if i'm looking at a wall with 6 metal panels on it, one of them might have a green or purple hue, or even a rainbow effect in some cases! I consider myself very lucky to even have the game as playable as it is, and fingers crossed i've had no storyline or game bugs as of yet. The texture thing just gets on my nerves, it kinda ruins the scene when your surrounded by rainbow textures splattered on everything.

 

The worst part is i KNOW this is fixable, as i had the same problem on kotor1, most noticibly on manaan. I cant recall if i fixed it or if it was a patch, for some reason "turn off triple buffering" rings a bell, but i tried that and no cigar.

 

It seems to be fairly uncommon as a search and a poke around on several forums has found nothing, not even other people with this problem!

 

I'll include my system specs, though the graphics card is most likley the only important information.

 

2.3 AMD

slightly overclocked saphire 9600xt

1gig ram

SATA hard drive

NF7-s Nforce 2 motherboard.

 

Oh, and its most definatly NOT overclocking the card causing the problem, as i used to have it on my good old geforce4 MX440 and even on this card long before i overclocked it.

 

The problem has also stayed throughout the latest ATI drivers since KOTOR2 came out. I am sure its a KOTOR2 problem, quite possibly something in the .ini file that needs to be added, i'm unsure.

 

I'll try and get a screenshot up a little later, but for now i'm going to go play it for a bit, i gave up holding out for the patch till i replayed again <_<

 

Thanks for your time guys (and guy-ettes).

 

EDIT: I now have pictures of it, now you guys can see why its so offputting!

 

Follow the linkage, click here!

Link to comment
Share on other sites

Well HUH!

 

Damn typical of me, fixed the problem right after i put up screenshots :">

 

INcase anyone else has this problem (unlikley) go to your "catalyst control center" or whatever tool you use for fiddling with your graphics card settings and chose "Disable catalyst AI" and your texture problems are now instantly fixed.

 

typical, pssh.... :-

Link to comment
Share on other sites

slightly overclocked saphire 9600xt

This right here is your issue. The odd color hues you are seeing are one of many types of "artifacts" that can occur from an overclocked GPU. You can accept these artifacts are minor problems that come as part of the tradeoff of a faster GPU, or you can return your GPU to stock speeds.

 

When overclocking a GPU, it is recommended that you use a burn-in program to thoroughly test the card and check for artifacts.

Link to comment
Share on other sites

Oh, and its most definatly NOT overclocking the card causing the problem, as i used to have it on my good old geforce4 MX440 and even on this card long before i overclocked it.

 

 

Well up thanks for your help in solving the problem, after i had solved the problem ;)

 

@ EnderWiggin: It definatly wasnt overclocking, because as it turned out, i had forgotten to write the overclocked settings to the cards bios, so when i had reset it went back to stock :">

 

@ Marka Ragnos: That would also make sense, however the source of my problem was the Catalyst AI, this isnt to say that mipmapping isnt the source of other peoples problems.

 

Thanks for the help anyway guys, hopefully it'll solve someones problems. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...