Jump to content

Can't play with sound!


Recommended Posts

I cannot play the game with sound! If I go into "swconfig.exe" and disable sound, they game works but then I have no sound. The game will not launch unless sound is disabled. I tired "Force Software Sound" but that doesn't make a difference - still won't launch the game. I also tried putting the Hardware Acceleration of my sound all the way down, but it still does not work. My Sound Card is Aureal Vortex. Help!

Link to comment
Share on other sites

  • 8 months later...

I have this same problem, and after an hour of searching around these forums, I couldn't find a solution. I'd much appreciate any advice on this problem -- I bought the game but have never been able to run it.

 

My soundcard is an E-mu 0404 (using a background application called "PatchMix DSP"). I've tried as an alternative to set the default audio playback device as the one that came standard in my Dell Dimension 4600 ("SoundMax"), but I still get the crash on starting up the game.

 

[sWKotOR]

ReportDateTime=2/22/2006 10:56:32 PM

SysInfoVersion=v1.00.60

GameExists=1

GameVersion=v2.10.427

GameInstallLocation=C:\Program Files\LucasArts\SWKotOR2\

 

[OS]

Name=WinXP

Version=Windows XP v5.1 build 2600 Service Pack 2

Service Pack=Service Pack 2

Status=Pass

 

[swapFiles]

C:\pagefile.sys=384

 

[CPU]

CPUCount=1

CPUSpeed=2992

CPUFamily=15

CPUModel=3

CPUStepping=4

CPUVendor=Intel

CPUName= Intel® Pentium® 4 CPU 3.00GHz

Status=Pass

 

[Memory]

RAM=2048

Status=Pass

 

[Disk Free Space]

C: (NTFS), UNICODE=13.21GB

F: (NTFS), UNICODE=1.48GB

G: (NTFS), UNICODE=383MB

H: (NTFS), UNICODE=25.55GB

Status=Pass

 

[CD-ROMs]

DriveLetters=D:\,E:\

Drives=ATAPI DVD RW,BENQ DVD DD DW1620,BENQ DVD DD DW1620,BENQ DVD DD DW1620,BENQ DVD DD DW1620,HL-DT-ST DVD-ROM GDR8163B

 

[Video]

Video Card Name=RADEON 9600 SERIES

Video Memory=256

Desktop Resolution=1680x1050x32 @ 60Hz

DirectX=DirectX 9.0c (4.09.00.0904)

OpenGL Version=2.0.5646 WinXP Release

OpenGL Vendor=ATI Technologies Inc.

OpenGL Renderer=RADEON 9600 XT x86/SSE2

ATI Driver=6.14.10.6599

Vid Card Status=Pass

Vid Card Driver Status=Pass

GL Status=Pass

DX Status=Pass

 

[Audio]

Sound Card Name=E-MU E-DSP Audio Processor (WDM)

Status=Pass

 

 

;Game Options from swkotor2.ini

 

[Display Options]

FullScreen=1

Disable Movies=0

Disable Intro Movies=0

Sort Modules=1

Width=640

Height=480

BitsPerPixels=32

RefreshRate=60

 

[sound Options]

Music Volume=85

Voiceover Volume=85

Sound Effects Volume=85

Movie Volume=85

Number 3D Voices=16

Number 2D Voices=24

2D3D Bias=0.50

EAX=0

Sound Init=0

Disable Sound=1

Force Software=0

 

[Graphics Options]

Grass=1

Shadows=1

EnableHardwareMouse=1

FullScreen=1

AllowSoftShadows=1

RefreshRate=60

Width=1280

Height=1024

V-Sync=0

Texture Quality=2

Anti Aliasing=0

Emitters=1

Anisotropy=1

Frame Buffer=1

Soft Shadows=0

Brightness=57

 

[Game Options]

Enable Tooltips=1

Keyboard Camera Deceleration=2000.000000

Keyboard Camera Acceleration=500.000000

Keyboard Camera DPS=200.000000

TextureVariation=0

BodyVariation=0

AppearanceType=0

PCGender=0

GameCompleted=0

CurSithLord=0

Hide InGame GUI=0

Use Small Fonts=0

Hide Unequippable=0

Tutorial Popups=1

Subtitles=1

Mini Map=1

Floating Numbers=1

Status Summary=1

Enable Mouse Teleporting To Buttons=1

Mouse Sensitivity=44

Difficulty Level=1

Auto Level Up NPCs=0

Mouse Look=0

AutoSave=1

EnableScreenShot=0

Reverse Mouse Buttons=0

Reverse Ingame YAxis=0

Reverse Minigame YAxis=0

Combat Movement=1

TooltipDelay Sec=1

Disable Movies=0

 

[config]

firstrun=0

 

[Keymapping]

Action286B=8

Action286A=7

Action285B=10

Action285A=9

Action284B=54

Action284A=51

Action283B=54

Action283A=51

Action282B=69

Action282A=73

Action281B=53

Action281A=76

Action280B=69

Action280A=73

Action268=52

Action265=58

Action264=57

Action263=43

Action262=85

Action261=84

Action260=83

Action259=82

Action258=81

Action257=80

Action256=79

Action255=78

Action254=77

Action253=31

Action245=75

Action244=55

Action243=67

Action242=74

Action241=87

Action240=56

Action239=68

Action238=82

Action236=83

Action234=81

Action232=80

Action230=79

Action228=78

Action226=77

Action225=70

Action224=90

Action223=31

Action222=25

Action221=24

Action220=29

Action219=28

Action218=42

Action217=87

Action216=65

Action215=63

Action214=60

Action213=62

Action212=61

Action211=66

Action210=59

Action209=71

Action208=89

Action207=72

Action206=30

Action205=55

Action204=67

 

[Autopause Options]

End Of Combat Round=0

Mine Sighted=0

Enemy Sighted=1

Party Killed=1

Action Menu=0

New Target Selected=1

 

[Movies Shown]

Movie10=0

Movie 9=0

Movie 8=0

Movie 7=0

Movie 6=0

Movie 5=0

Movie 4=0

Movie 3=0

Movie 2=0

Movie 1=0

Movie 0=0

Link to comment
Share on other sites

1. Enlarge your swap file. The current one (384) is very tiny...

 

2. Try to see if there are updated drivers for both your video as your sound card...

Thanks for the advice. I have the most recent drivers for my ATI Radeon 9800XT as well as my E-mu 0404 soundcard. I also increased the pagefile to 784 MB minimum and maximum as you advised (though I had never thought it an issue as I have 2gb of PC3200 RAM).

 

Same problem. It's so widespread, I'm shocked that LucasArts or Obsidian hasn't addressed it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...