Jump to content
  • 0

Title menu graphical errors


thomas9000

Question

image.thumb.png.fb821fc456383467a0e70ff8bd23b3bf.png

 

I recently installed Deadfire again on a new PC. If it is of any importance I have all of the dlc

At first it ran well. Then I remembered that there are some really good mods for the game so I installed them. community patch, enhanced ui etc.

At first I ran into a blackscreen, I did some digging and thought it had to do with the mods, i tweaked abit with that and I started getting the above result instead.

- First I uninstalled all of the mods and tried to start the game again, same result.

- Reinstalled the game without mods and restarted my PC, same result.

Im at wits end, I cant find anyone who has a similar issue. 

Help would be appreciated.

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0
Posted (edited)

Ooph that's a weird one. What it looks like it some of the ".assets" files might have become corrupted. The files "sharedassets0.assets", "sharedassets0.assets.resS", "sharedassets1.assets" and "sharedassets1.assets.resS" are the files that contain the assets for main menu start up. If those are present in the "PillarsOfEternityII_Data" directory, try deleting them, then verifying the integrity of the game files through GoG-Galaxy/Steam

Edit: Did you install any mods that require the Unity Mod Manager to work?

Edited by Kvellen
Link to comment
Share on other sites

  • 0

So this issue seems to be related to Unity Mod Manager recently updating to Harmony 2.3, which isn't compatible with Deadfire. To fix this Open UnityModManager and uninstall it from Deadfire then close UMM. Open Deadfire and the main menu should now load as normal.

To continue using UMM mods with Deadfire. Open the "UnityModManagerConfig.xml" file in the UMM with notepad. Search for "Deadfire" then add <HarmonyVersion>2.2</HarmonyVersion> at the end of the section like so:

<GameInfo Name="Pillars of Eternity II: Deadfire">
  <Folder>Pillars of Eternity II Deadfire</Folder>
  <ModsDirectory>Mods</ModsDirectory>
  <ModInfo>Info.json</ModInfo>
  <GameExe>PillarsOfEternityII.exe</GameExe>
  <EntryPoint>[UnityEngine.UI.dll]UnityEngine.Canvas.cctor:Before</EntryPoint>
  <StartingPoint>[Assembly-CSharp.dll]Game.GameState.Awake:After</StartingPoint>
  <UIStartingPoint>[Assembly-CSharp.dll]Game.UI.UIMainMenuManager.OnyxStart:After</UIStartingPoint>
  <MinimalManagerVersion>0.22.3</MinimalManagerVersion>
  <HarmonyVersion>2.2</HarmonyVersion>
</GameInfo>

Save the changes.

Install UMM to Deadfire as you did previously.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...