Jump to content
  • Sign Up
  • 0
GabrielleK

Pillars 2 Not Loading Following Mac IOS Update to Catalina

Question

7 answers to this question

Recommended Posts

  • 0

Apple dropped 32-bit support.

So if Pillars is not an 64 bit APP or some middleware its uses, then it wont load.

I fear Pillars needs to be updated to a more recent Unity engine version and I do not think this is going to happen.

MacOS 10.15 UnityEngine Support:

2017.4 LTS
2018.3/LTS
2019.1+

Edited by Aurelio

Share this post


Link to post
Share on other sites
  • 0

I am also having this issue.

Pillars 2 is just jumping in the dock. No way it will launch. 

It even asked me full keyboard access (that is access the keyboard usage while other apps are in use! WTF?!) 

Why is Pillars 2 not working on macOS Catalina? 

Is Pillars 2 really a 32-bit app or has it any 32-bit component? 

Please fix it. We paid for this game.

Share this post


Link to post
Share on other sites
  • 0

I have a mid 2015 Retina iMac with the latest version of Mac OS Catalina, POE i, II both work fine... Fairly clean system with only; Kaspersky, M$ office, Firefox (latest) Thunderbird (latest) no other hacks... NO MODS.  Try re-installing.  I found erasing game saves (that were corrupted) from earlier versions made a huge difference (although loading was never an issue).

 

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, LotharVI said:

I have a mid 2015 Retina iMac with the latest version of Mac OS Catalina, POE i, II both work fine... Fairly clean system with only; Kaspersky, M$ office, Firefox (latest) Thunderbird (latest) no other hacks... NO MODS.  Try re-installing.  I found erasing game saves (that were corrupted) from earlier versions made a huge difference (although loading was never an issue).

 

Thanks!

I had already reinstalled but the game just keeps bouncing in the Dock... I will try to uninstall everything Steam and try again... 

Share this post


Link to post
Share on other sites
  • 0

I have just reinstalled Steam.

Redownloaded PoE2... it is now bouncing on my Dock and not launching.

Other games installed in Catalina had a "Verifying <gamename>" progress bar from the operative system.

PoE2 doesn't have it. Now the icon stopped bouncing but doesn't have the dot below the icon to show it is running. Nevertheless, if I go into the Force Quit menu PoE results as running (so it is not hanging). In Activity Monitor XProtectService is the highest energy consuming process. 

The disk is working a lot so I suspect something is happening but the game is not launching at all. What can I do now?

Share this post


Link to post
Share on other sites
  • 0

I found a solution to run:

1. Opem Terminal

2. Put there:

/Users/YOURUSERNAMEINMACOS/Library/Application\ Support/Steam/steamapps/common/Pillars\ of\ Eternity\ II/PillarsOfEternityII.app/Contents/MacOS/PillarsOfEternityII ; exit;

But I hope developers will fix it soon 😔

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...