Jump to content
  • 0
tedmann12

Game running choppy suddenly?

Question

Anyone know why my game is suddenly running choppy? Every 5-10 seconds as I'm running around the game freezes for like half a second.
 
I have a gtx 1080 and an i7700k. Normally run the game flawlessly.

 

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Hello Tedmann,

 

I'm sorry to hear Deadfire is not running as smoothly as it once was for you.  Have you noticed any changes since the last time you played before the issue occurred?  Has the game or any hardware you might have been updated since?  Generally updating graphics drivers and the operating system can help to fix such issues, but sometimes the older drivers happen to run better, in which case users will revert back to those.  It is also possible that repairing or reinstalling the game can help restore the performance.  Please let me know if any of these diagnostic steps help get you running smoothly again.  If they don't help, then I'd recommend reproducing the issue and then sending us the output_log.txt file so we can see if there is anything displayed there that can tell us what is going on.  if needed, you can find instructions on how to obtain the output_log.txt file here.  If you could send that to me at support@obsidian.net along with a link to this thread as a reference, I can have someone take a look and see if there is anything going on in the background.

 

Thank you Tedmann and sorry for the inconvenience this is causing.

Share this post


Link to post
Share on other sites
  • 0

 

Anyone know why my game is suddenly running choppy? Every 5-10 seconds as I'm running around the game freezes for like half a second.

 

I have the same issue.  i5-8400, RTX 2080.  16GB RAM.  165hz monitor/G-sync.  No mods installed.

 

Doesn't matter what type of settings I force upon the game, it will continue to freeze as described by Tedmann.  It's tolerable outside of combat, but it happens even more often in combat and it's borderline unplayable.  This issue isn't recent, but I was able to use the special-K workaround in the previous patches which helped a bit, but it wasn't perfect.  This doesn't work anymore.

 

I've tried:

  • Repairing, and reinstalling the game.
  • Installing the game on three different SSDs.
  • Forcing 30hz/60hz (30 FPS/60FPS) Vsync off/on, gsync off/on
  • All Nvidia driver releases between 398.82 > 419.35 (Fresh installs using DDU)
  • Special-K mod forcing 30/60 FPS, spoofing core counts.
  • Everything listed in this post.
  • New, fresh windows install with fresh drivers.
  • Disabling telemetry and steam overlay.
  • Closing or stopping *all* other third party applications on my PC including antivirus, etc.
  • Multiple combinations of the above.

I've put hours on hours trying to get the game to run smooth, but nothing I do seems to work.

 

I would love to finally get around to playing the DLC, but can't enjoy the game in its current state.  I've emailed the output log as requested by the mod.

Share this post


Link to post
Share on other sites
  • 0

I'm having a similar issue, forcing a higher virtual resolution seemed to have a somewhat positive effect on the stutter. This made it more playable for me, now I'm just waiting on the suppress affliction bug to get fixed. Another thing to try is forcing exclusive fullscreen, and d3d11 as launch options.
-force-d3d11 -window-mode exclusive

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

I'm having a similar issue, forcing a higher virtual resolution seemed to have a somewhat positive effect on the stutter. This made it more playable for me, now I'm just waiting on the suppress affliction bug to get fixed. Another thing to try is forcing exclusive fullscreen, and d3d11 as launch options.

-force-d3d11 -window-mode exclusive

 

Unfortunately, this did not seem to do the trick either. :(  Thank you for the suggestions!  Also, absolutely certain I'm not using any mods.

Edited by JPraski

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Try running it as administrator? Or in an earlier windows compatibility mode? Alt-tab back and forth?

Edited by rockfish42

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

My stutter was about every 30 seconds or so, it's at least playable if annoying. I have an AMD card, I think it's just exacerbated by the NVIDIA issue. Another random suggestion, do you have Window's Night Light enabled? My problem was worse with F.lux and they do similar things.

Edited by rockfish42

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Fingers are crossed, but I think I fixed it.

 

I had a chance to try the game on another PC (i5 4590, AMD card).  I was logged into my steam account on their PC, no stuttering on any of the save games I loaded up onto her PC.  Closed the game, steam mentioned that the save games on my cloud and on this PC didn't match up, and asked which saves I wanted backed up.  I chose to upload her saves to try on my computer -- after a sync on my PC, booted up her save game and lo and behold, it ran flawlessly. 

 

I don't think it was any of my save files being corrupted since any new game I started had the problem.  Edit: I copied my broken saves to two other PCs and the saves were still a stuttery mess.  Leads me to believe that whatever is causing the issue exists from the moment you first load into the game and will be present until the very end, regardless of hardware specifics.

 

After the sync, it also synced her achievement progress since I'm now missing a quite a few Berath's Blessing points and achievements.  It appears that steam syncs that entire 'Saved Games > Pillars of Eternity II' folder each time you close the game, and whatever was causing the issue is related to the data saved in that folder.  Explains why the issue persisted even after I reinstalled windows, steam and POE2 since steam cloud just re-downloaded whatever was causing the problem each time.  Of note, the game settings remained unchanged after the sync.

 

Thanks for the help!

Edited by Nehm

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...