Jump to content
  • 0
Watchlord

Serafen Wants To Talk, but Says Nothing. Bug?

Question

Serafen wants to talk but has nothing new to say. I just completed "A Sorcerer and a Gentleman", talked Malnaj out of fighting (Principi +2), and spoke to Serafen onboard my ship about the slavers (before the icon appeared), but the icon persists. He just has his ordinary lines when I talk to him. Can I fix this with the console?

 

Image Attached.

 

post-170324-0-31494900-1546012896_thumb.jpg

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hey, I had the same bug and got the reply that the issue is known and is being investigated, no fix for now it seems.

 

If any devs are reading this, I'd still appreciate clarification on if this is a matter of new dialogue not triggering when it should, or just a visual bug where the speech bubble is there even though no new lines are supposed to be unlocked.

Share this post


Link to post
Share on other sites
  • 0

I got Serafen to speak and then his speech bubble went away.

Did "A Sorcerer and a Gentleman" > Erroneous bubble appears > Get Crookspur slave quest > Go to Crookspur and buy a slave, talk to slaver guy, release slave > Go talk to Huana up north about slaving, agree to kill slavers for them > Immediately after conversation ends about slaves/Leaden Key, Serafen accuses you of slaving and the bubble is gone.

Went back and killed all the slavers without talking to them first and Serafen is still bugged. It seems that doing something negative is the only way to kick that bubble.

Share this post


Link to post
Share on other sites
  • 0

Hey, I had the same bug and got the reply that the issue is known and is being investigated, no fix for now it seems.

 

If any devs are reading this, I'd still appreciate clarification on if this is a matter of new dialogue not triggering when it should, or just a visual bug where the speech bubble is there even though no new lines are supposed to be unlocked.

TBH, this bug has been ubiquitous since the beginning, has been especially rampant on Xoti, and despite having been "looked at" for more than a year, it's still popping exactly as much as the day of release.

In fact, I even checked if I didn't install the game with an old file (from GOG) because I am constantly pretty often such sort of glitches that were supposedly "looked at" or "fixed" for months and month.

 

I'm pretty tolerant of buggy release, but FFS we're one whole year and three DLC later, at patch 4.0, and it's not acceptable anymore.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...