Jump to content
  • 0

Deadfire 3.07 Pack?


Question

I am currently running version 3.06 of Pillars with both White March packs; I just found out about the Deadfire pack with new portraits and vendor etc, but how can i download it?

 

I didn't use GOG or Steam for my original download (I used Amazon), and can't find ANYWHERE online where I can update my game with the free Deadfire Pack.

 

Please Help!

Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Pillars 2 Deadfire is a new game, linked in several ways to Pillars 1 but with different rules: it follows Pillars I plot, some characters are the same, some spells are the same, some weapons are the same and if you played Pillar I you find in PIllars II several old "friends", but it is a new game, differnt SW and different rules.

Link to post
Share on other sites
  • 0

I am currently running version 3.06 of Pillars with both White March packs; I just found out about the Deadfire pack with new portraits and vendor etc, but how can i download it?

 

I didn't use GOG or Steam for my original download (I used Amazon), and can't find ANYWHERE online where I can update my game with the free Deadfire Pack.

 

Please Help!

 

This is POE1 forum not POE2

Link to post
Share on other sites
  • 0

The Deadfire Pack is a free DLC for Pillars 1, so this is the correct forum.

 

As for the question: Sadly no clue, I use GOG myself. I would stay on 3.06 anyway, because 3.07 made the game backgrounds blurry and most of the Deadfire irems are bugged. The pack and patch are a nice gesture but terribly executed...

  • Like 1
Link to post
Share on other sites
  • 0

The Deadfire Pack is a free DLC for Pillars 1, so this is the correct forum.

 

As for the question: Sadly no clue, I use GOG myself. I would stay on 3.06 anyway, because 3.07 made the game backgrounds blurry and most of the Deadfire irems are bugged. The pack and patch are a nice gesture but terribly executed...

cant fully confirm that, seems to affect not all users/installations.

 

when running latst version 3.07.0.1318 (here GoG) with the deadfire dlc and the patches for the dlc (those are 3, not 1, you have to apply a patch to vanilla files and a patch for each expansion. some users fail here and getting the pink voids) the game runs smooth and at least i dont have blurry textures (but that may differ with hardware). To be safe download the complete pack form gog again if you use the gog version, since they update the package from time to time.

 

the deadfire item thats notably bugged is the soulbound arablest, but there is a community fix for it.

 

Link to post
Share on other sites
  • 0

Trust me - I tried everything to fix the blurry backgrounds and nothing helps besides using 3.06 instead of 3.07. My guess is they changed something in the renderer. I think some people have this but don't even notice (or care) but for me it's VERY irritating. Maybe it is hardware related and not affects everyone. If so, then I may just have rotten luck, but there is nothing on my end that I can do to confirm or deny that. So I stay to what I posted before and just avoid 3.07 altogether.

 

And for the bugged items: There is more than that. The three pirate uniforms for example are bugged as well and are invisible/white on all male characters. The pirate hat also had a problem, but it may be that it got patched - I don't know anymore...

Link to post
Share on other sites
  • 0

Trust me ..

No. ;)

 

 

Thats ofc not personal, just a emotionless, rational statement based on experience ;)

if youve seen what ive seen you will come to same conclusion.

ppl usually lack in:

 

- attention span

- patience

- proper reading

- elaborateness

- clear view

- proper knowledge&skills to classify

- alot of dunning-krueger

and so on.

 

just look at one of the latest "bugreports" where someone pukes some text, upset, temper like a little kid, in such a mindless way that absolutely no info about his system (hw+software) is supplied at all ... ofc expecting a solution and blaming it all on the game

 

 

hm, just some (additional) ideas (besides that i agree that something in renderer may have changed):

- did you try disable or force/override aa/af (and other) settings driverside?

- did you try running w/ w/o dwm (desktop windows manager)?

- did you try different dx versions / open gl via commandline option?

 

second and now were coming to one of the points why i dont trust ppl. attention for details-

it has a reason i typed the complete version number. Until you name the exact version youre running, 

discussion is rather pointless. because:

there are 2 different 3.07 (- 3.70) versions: 1280 and 1381. when i name the complete version i expect that others do that too, to make sure we talk about the same. i really suck @mindreading ;)

 

And for the bugged items: There is more than that. The three pirate uniforms for example are bugged as well and are invisible/white on all male characters. The pirate hat also had a problem, but it may be that it got patched - I don't know anymore...

and here we go. The bugs you describe are part of 1280 but are fixed mho in 1381*. i just did a test and the pirateuniforms display correctly on all (my) male characters. The bug with the captains hat was fixed too (one of the effects triggered wrong)

 

that doesnt mean its bugfree, just saying its really important to be exact here.

 

* patch(es)1381 had to applied properly

 

Edited by hcl
Link to post
Share on other sites
  • 0

Well, then don't trust me. :p But I'm a sucker for details and as these blurry backgrounds drive me mad, I tried everything that came to my mind - should have added this earlier.

 

And yes, I have 3.07.1318. I also don't have any issues regarding patch-order, because I downloaded the install and data files for 3.07.1318 (main game and both expansions) so no further patching is necessary.

 

- did you try disable or force/override aa/af (and other) settings driverside?

Yes, makes no difference for me (In fact I once disabled ANY driver related additions, enhancements, whatever... and also tried different driver versions - to no avail.)

 

- did you try running w/ w/o dwm (desktop windows manager)?

Truth be told I'm not familiar with that, but will take a look now. So thanks.

 

- did you try different dx versions / open gl via commandline option?

Yes, makes no difference for me

 

 

Regarding those uniforms: Would you be so kind to post a screenshot of those uniforms working, please? Because I cannot verify that. I installed 3.07.1318 again to test this and this is what it looks like:

 

My male PC

1.png

 

 

Grieving mother (same color scheme as PC)

GM1.png

 

 

Comparison between the two

GM2.png

Edited by Cerebro83
Link to post
Share on other sites
  • 0

Ok, a case of misunderstanding and -interpretation, perception and expectations (and sorry that it made you unneccessary reinstall the game) :)
Those uniforms here on male Characters look the same as in your screenshots. Frankly, from the Bug descriptions ive read, i expected them beeing either totally non-visible on male characters or looking like (other poes) tabula rasa, complete uni / white colored like the pink blob bugs w/o any textue. For me they looked ok on first glance and halfway intended since i dont give _that_ much on looks ingame anyway. Now staring at them they feel ofc buggy .. *damn*.
It _may_ be not too complex too fix if values can be compared form female and male version in the assetbundles. But thats no educated guess.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...