Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Crashes During Quick Load at Sea


  • Please log in to reply
3 replies to this topic

#1
Skie Nightfall

Skie Nightfall

    (4) Theurgist

  • Members
  • 324 posts
  • Location:Israel
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

Can't find a specific cause. All I know that twice I crashed while quick loading at sea.

Once during the conversation with Captain Furrante, and second time while I was on the ship after the scripted interaction with the gods, that happens after I started sailing toward Neketaka for the first time.

Those crushes also don't seem to be creating dumps!

And I'm having difficulties capturing the error massage since I can't see it clearly until all dies. I think it's a runtime crash though.



#2
SChin

SChin

    Product Services Manager

  • Developers
  • 890 posts
  • Location:Irvine, CA

Hello again Skie!

 

I'm sorry you've run into these crash bugs.  It's odd that they aren't creating logs.  I'll report this and tell the team to keep an eye out for anything similar.  If you discover anything else about this, please let me know!

 

Thanks again, and sorry for the inconvenience Skle.



#3
Skie Nightfall

Skie Nightfall

    (4) Theurgist

  • Members
  • 324 posts
  • Location:Israel
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

Just happened again on latest 2.1 patch.

Again, I was on the ship and it happened while quick loading.

Managed to capture the crash error this time, but there's no dump.

Attached Files


Edited by Skie Nightfall, 12 September 2018 - 07:31 AM.


#4
Skie Nightfall

Skie Nightfall

    (4) Theurgist

  • Members
  • 324 posts
  • Location:Israel
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

Seems to be happening anywhere, but I've managed to reproduce it.

What it takes is quickloading a few time in a row straight away.

I just managed to get this crash twice by quickloading quickly three times in Tikaware.
My guess is that something doesn't finish to load properly or there's a leak/garbage somewhere, causing the function call to miss the derived class.


Edited by Skie Nightfall, 16 September 2018 - 11:16 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users