Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Kotor 2 won't start and i've tried everything


  • Please log in to reply
12 replies to this topic

#1
agrash

agrash

    (1) Prestidigitator

  • Members
  • 5 posts
So i've installed kotor 2:
-patched the game to 1.0b
-changed the 'mss32.dll'
-tried either ‘Run as Windows XP’ or ‘Run as Windows 2000’


But so far no luck on getting the game to run while KOTOR1 ran perfectly without even patching the game :*
The game just crashed immediatly with an error saying that the game doesn't work anymore and it needs to shut down

One more thing: When i click on "scan hardware" i get this error (since i have an updated ATI card i didn't paid attention to it)
Posted Image



I have:
Vista home premium 32 bits
service pack 1
quad core q6600 @ 2ghz
ram: 2 gb
ati: hd 2600 pro

I hope someone can help me, i really want to see what this game brings :o

Edited by agrash, 06 April 2009 - 12:16 PM.


#2
agrash

agrash

    (1) Prestidigitator

  • Members
  • 5 posts
Sorry, i forgot to post my dxdiag

------------------
System Information
------------------
Time of this report: 4/6/2009, 23:25:06
	   Machine name: PC_VAN_JONATHAN
   Operating System: Windows Vista™ Home Premium (6.0, Build 6001) Service Pack 1 (6001.vistasp1_gdr.080917-1612)
		   Language: Dutch (Regional Setting: Dutch)
System Manufacturer: ACER
	   System Model: Aspire M5620
			   BIOS: Default System BIOS
		  Processor: Intel(R) Core(TM)2 Quad CPU	Q6600  @ 2.40GHz (4 CPUs), ~2.4GHz
			 Memory: 2046MB RAM
		  Page File: 1616MB used, 2717MB available
		Windows Dir: C:\Windows
	DirectX Version: DirectX 10
DX Setup Parameters: Not found
	 DxDiag Version: 6.00.6001.18000 32bit Unicode

---------------
Display Devices
---------------
		Card name: ATI Radeon HD 2600 PRO
	 Manufacturer: ATI Technologies Inc.
		Chip type: ATI Radeon Graphics Processor (0x9589)
		 DAC type: Internal DAC(400MHz)
	   Device Key: Enum\PCI\VEN_1002&DEV_9589&SUBSYS_2E42174B&REV_00
   Display Memory: 1013 MB
 Dedicated Memory: 245 MB
	Shared Memory: 767 MB
	 Current Mode: 1152 x 864 (32 bit) (60Hz)
		  Monitor: Algemeen PnP-beeldscherm
	  Driver Name: atidxx32.dll,atidxx64,atiumdag.dll,atiumdva.dat,atiumd64,atiumd6a,atitmm64
   Driver Version: 7.15.0010.0127 (English)


If someone needs the entire notepadfile, just give me a shout and i'll upload it ;)

#3
Darth Mortis

Darth Mortis

    (6) Magician

  • Members
  • 793 posts
  • Location:Right behind you.....
The steps you've taken to get KOTOR2 working on your PC don't always work. There are two threads on this part of the board detailing all the various ways to get the game to work - I'd run down that list.

I usually ignore the KOTOR system check, since ever since I played K1 it has told me that the game wouldn't run - this on two different computers. Still, it might be a good idea to double check your graphics drivers anyway.

#4
agrash

agrash

    (1) Prestidigitator

  • Members
  • 5 posts
Which threads?? i must have missed them
I checked out this: http://forums.obsidi...mp;#entry760302
but nothing helped


+ even if there's a new graphic's update available, i doubt it'll run an old game like kotor 2


Oh and i tried something but it isn't a cure. I can apparently run the game but without enabling the sound so thats no sollution. Ok you can probably use subtitles but would you watch a movie without subs?? ^^

#5
kmja

kmja

    (1) Prestidigitator

  • Members
  • 15 posts
did you get the KOTOR to work whitout any problem if so how did you do it?

#6
agrash

agrash

    (1) Prestidigitator

  • Members
  • 5 posts
Like i said, i ran kotor perfectly without even patching the game.
Just install & play. No errors, problems, issues whatsoever

#7
kmja

kmja

    (1) Prestidigitator

  • Members
  • 15 posts
i have the star wars best buy so i have the lastest patch on :lol: and when i play it the game frezze on me ;(

#8
Darth Mortis

Darth Mortis

    (6) Magician

  • Members
  • 793 posts
  • Location:Right behind you.....

Which threads?? i must have missed them
I checked out this: http://forums.obsidi...mp;#entry760302
but nothing helped


+ even if there's a new graphic's update available, i doubt it'll run an old game like kotor 2


Oh and i tried something but it isn't a cure. I can apparently run the game but without enabling the sound so thats no sollution. Ok you can probably use subtitles but would you watch a movie without subs?? ^^


http://forums.obsidi...showtopic=50140

http://forums.obsidi...mp;#entry760302

#9
agrash

agrash

    (1) Prestidigitator

  • Members
  • 5 posts
So my last chance is to contact securom apparently.
Thx

Edited by agrash, 07 April 2009 - 09:05 PM.


#10
Casca O

Casca O

    (0) Nub

  • Members
  • 1 posts
I have a similar problem however these suggested fixes don't fix the problem since I'm running on XP (funny enough he's running the same system I am on Vista)

#11
Belhawk

Belhawk

    (3) Conjurer

  • Members
  • 167 posts
kotor fixes from lucas forums
it also includes an ini fix too,
* First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor(2)\swkotor(2).ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
* When you find it, just double-click on the file to open it in Notepad.
* Scroll down the file until you find the Graphics Options
* Under the last line ("last line" as in the last line of the list of entries under "Graphics Options", NOT the last line of "swkotor(2).ini), add "Disable Vertex Buffer Objects=1", without the quotes.
* Goto File, then Save.

#12
TUHD

TUHD

    (1) Prestidigitator

  • Members
  • 8 posts
  • Backer
In case you've got KOTOR 1 and 2 (both installed from CD, not 1 from Steam or so) - copy the .ini file from KOTOR 1 to KOTOR 2 if I recall OK and it should work.
Also - ignore the system check like others said - all graphics card above GeForce 4000 (+-) get an error from it. Too new drivers

kotor fixes from lucas forums
it also includes an ini fix too,
* First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor(2)\swkotor(2).ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
* When you find it, just double-click on the file to open it in Notepad.
* Scroll down the file until you find the Graphics Options
* Under the last line ("last line" as in the last line of the list of entries under "Graphics Options", NOT the last line of "swkotor(2).ini), add "Disable Vertex Buffer Objects=1", without the quotes.
* Goto File, then Save.


Edited by TUHD, 17 September 2009 - 10:05 AM.


#13
Krelbourne

Krelbourne

    (0) Nub

  • Members
  • 1 posts
I have the same problem as the other guy

I installed the game perfectly and as i go to launch it stops working, so i do a system check and it shows that my graphics card isnt sufficient.
but then the game works if i turn off the sound from the configure window. i would really like to play this game with sound and all before the Star Wars MMO comes out.


can someone help??




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users