Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

KOTOR 2, Problem with patch 1.0b


  • Please log in to reply
2 replies to this topic

#1
DarkPadawan

DarkPadawan

    (0) Nub

  • Members
  • 1 posts
Dear Obsidian Team,

I recently purchased the UK version of KOTOR 2 and installed it on my gamer machine:

Athlon X2 3800+, 1 GB RAM (Dual Channel), NVIDIA 7800 GTX (drivers updated yesterday), SB Audigy 2 ZS, Direct X 9.0c, WinXP SP2 + several hotfixes.

After installing the game, I tried to start it and it worked... after applying the first official patch it still worked... after applying the second patch (1.0b, 16MB), I tried to start the game...

...and got a Windows error, even before the LucasArts Logo appeared. The CD didnīt even start to spin... :aiee:

So I uninstalled and tried the whole procedure again, but it didnīt help. After doing it for a third time on a different HD-partition and still no success, I felt funny and manually copied the swkotor2.exe from the game disk over the patched EXE... and, strange enough, the game runs. I played for about an hour (Oh man, great game...) and went to bed.

My fear is now, that the game will hang or abort sometime in the future, since the original swkotor2.exe is only half the size of the patched (1.0b) one and will probably not be compatible with all the other patched files...

What am I to do? Re-install and play without patches? Re-install and just apply the first patch? Game on and hope for the best? What is wrong with patch 2?

Thanks,
DarkPadawan

#2
LadyCrimson

LadyCrimson

    Forum Moderator

  • Moderators
  • 7580 posts
  • Location:Candyland
  • Gold Backer
  • Kickstarter Backer
Welcome to the forums. :aiee:

Sounds like a weird situation; hopefully someone will have some definitive answer for you. It's possible you may just lose out on some of the patch effects w/out crashing, but I'm not sure. If it were me, I'd just keep playing and see what happens.

If you're really worried about losing progress or something, then play w/out the patch. It doesn't really do anything horrendously neccessary to the game...some even suggested it made their game run worse. Such is the way of computers. :aiee:

#3
Evil Penguin

Evil Penguin

    (1) Prestidigitator

  • Members
  • 22 posts
First of all, I hope it's ok to say what I'm saying below. I think it should be as this is a problem that probably only affects us legitimate game owners and as it doesn't seem likely that this will ever be fixed officially.


I think the problem you're experiencing is the same as the one I ran into when I installed the game again (I had the game running on this same machine around the time when the game was pretty new).

I didn't try reverting to 1.0, but my fresh installation, with the same "a", "b" and "movie" patches applied as I had the last time I played the game, it crashed immediately the same way you described. It didn't spin up the CD or anything, I just got the "send crash info to microsoft?" dialog immediately when starting the game.


I'm reasonably confident that this crashing problem in the "b" version is due to the different Securom version used in the "b" patch.
And, to no huge surprise, the game ran perfectly if I applied a third party *cough* nocd *cough* patch for the "b" version.

I don't recall if I had to resort to this same workaround the last time I played the game or if the "b" patch worked back then, but I do recall that there were a fair share of people on the forums who couldn't get the game to run for this exact reason back when the "b" patch was initially released. (That's where my idea on the cause and how to work around it came from.)

I hope this can help someone, or preferably that an official solution can finally be released, but that doesn't seem very likely at this point.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users