Jump to content
  • 0

Can't Find Code for Obsidian Edition Upgrade


Question

Bought RotR on Android many months ago, i went thru the Ambassador Program page, it told me I would get code for 10% off coupon and Upgrade to Obsidian Edition. I used the coupon, but on the My Products page of my account it doesn't list a code for Obsidian Edition, and Steam says it isnt purchased.

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

There is no Obsidian Upgrade code.  The process is automatic after verifying your PFID and then linking up your Steam account.

 

After you've logged into the website with your new Obsidian account, make sure to go to:

https://pathfinder.obsidian.net/steam-promo

to link everything up.

 

After the process completes completes verification, all the DLC packs will be added to your account, no keys required.

 

The full instructions are here, if you haven't already checked them out.  The first post explains which steps are required to redeem the free content.

Link to post
Share on other sites
  • 0

I've been having issues with this. It said an error occurred when entering my PFID twice so I tried to do it again later.

 

Now I get:

"

Pathfinder Adventures Steam Promotion

As a thank you to our community and to celebrate our recent launch of Pathfinder Adventures on PC and Mac, Obsidian is providing anyone with a registered Obsidian account with:

  • A Steam coupon for 10% off Pathfinder Adventures (base game or Obsidian Edition)
  • Exclusive in-game, digital promo cards featuring Edér and Pallegina from Pillars of Eternity II: Deadfire and the Goblin Golem of Obsidian

 

You have already completed account verification for this promotion. Please visit your My Productspage to see your available codes and/or keys.

"

I bought the game on Steam but there's no upgrade. I can only assume that the PFID didn't work but there is no way I can find to enter it. Does this mean I just need to refund the game on Steam or is there a way to still get my free upgrade (yes to confirm I have the Rise of the Runelords bundle). How do we fix this? Can't seem to find a contact in support.

 

Thanks

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...