Jump to content
  • 0

Lost my treasures


Rackshaw

Question

I lost 2 treasure chests this evening. I bought all three this evening and then when I tried to open them the screen went to the chest opening screen but didn't expand to the 4 cards. Thinking it was a glitch I closed the program and tried again; happened a second time. I have gone in the gallery and have gained nothing.

 

I am running the game on an iPad mini 4, iOS 10.2.1, PFID-AB1B65056B824FDA

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...