Jump to content
  • 0
Sign in to follow this  
marietto86

I have some bad Framerate drop

Question

Hi everyone,

 

2days ago i bought Pillars of Eternity (and it seems to be a very good game), but i have some fps problems.

 

I only played 1-2hours, at the beginning of the game when the caravan stop, when it's full of people around the game starts to have some fps drop... instead when i was in the cavern nothing to say, everything was Ok.

Later, when i arrived at Gilded Vale and i went to the Black Hound's inn, Omg it started to go slooooowly, a lot of fps drop :(

 

i tried to put everything on low settings, no vsync, no antialiasing, even with the lowest resolution it lags.

 

What could be the problem? Is there any solution?

 

My Pc Spec:

 

Windows 10 (updated)

 

Nvidia Gtx 760 (driver updated)

 

Intel i5-2500 CPU @ 3.30GHz

 

8gb Ram DD3

 

Yeah it's not a super pc, but even so bad... every other games that i am playing works fine.

 

Thanks.

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...