Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

BlackScreen at start up

blackscreen wont start issue

  • Please log in to reply
13 replies to this topic

#1
LonelyFatGuy

LonelyFatGuy

    (0) Nub

  • Initiates
  • 4 posts
  • Deadfire Backer
  • Fig Backer

Hello, 

 

I played the game yesterday and everything was fine, the next day i tried to start it up and all i get is a black screen and music.

The mouse is turned into the glove and i can move it around, even clicking on the now hidden menu, i veen managed to load a game but everything stayed black.

 

i tried reinstalling and verifying the cash, but it didn't work. my drivers are updated too.

I was really looking forward to playing the game, can anyone help?

 

 



#2
Suen

Suen

    (4) Theurgist

  • Members
  • 399 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

Could you upload the output_log.txt and the system informations?

You can find the location of those files here.



#3
jeremyme

jeremyme

    (0) Nub

  • Initiates
  • 2 posts

Having same issue as LFG, except that I haven't been able to get it to load at all. Only a black screen, a hand, and music on a Windows 10 PC. Others have suggested disabling Crossfire, but I'm pretty sure I don't have that. I've spent 3-4 hours trying to find a fix or a workaround, but I haven't even made it past this initial black screen. Any help would be greatly appreciated.

 

My output log:

Attached File  output_log.txt   18.85KB   6 downloads

 

My system specs:

Attached File  DxDiag.txt   89.79KB   3 downloads

 

Thanks,

J



#4
Suen

Suen

    (4) Theurgist

  • Members
  • 399 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

Can't say if it's important, but in your log the game starts with the Intel integrated graphic card, not the Radeon.

Any energy saving profile active?



#5
LonelyFatGuy

LonelyFatGuy

    (0) Nub

  • Initiates
  • 4 posts
  • Deadfire Backer
  • Fig Backer

Here is my log data

Attached Files



#6
Xaratas

Xaratas

    (7) Enchanter

  • Members
  • 901 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

@LonelyFatGuy

Your game runs in window mode, try to change the file prefs next to the output log and check/change booth lines which contains fullscreen to 1

    <pref name="FULLSCREEN" type="int">1</pref>
    <pref name="Screenmanager Is Fullscreen mode" type="int">1</pref>


#7
jeremyme

jeremyme

    (0) Nub

  • Initiates
  • 2 posts

Suen,

 

Thanks for your reply. I did have an energy-saving profile active. I have since changed it to high performance but am getting the same result. I'm not sure why it's booting with the Intel® HD Graphics card and not the AMD Mobility Radeon HD 5000.

 

J.



#8
LonelyFatGuy

LonelyFatGuy

    (0) Nub

  • Initiates
  • 4 posts
  • Deadfire Backer
  • Fig Backer

 

@LonelyFatGuy

Your game runs in window mode, try to change the file prefs next to the output log and check/change booth lines which contains fullscreen to 1

    <pref name="FULLSCREEN" type="int">1</pref>
    <pref name="Screenmanager Is Fullscreen mode" type="int">1</pref>

i change this in the output_log?

 



#9
LonelyFatGuy

LonelyFatGuy

    (0) Nub

  • Initiates
  • 4 posts
  • Deadfire Backer
  • Fig Backer

i keep geeting a crash, saying the display driver stopped responding 

Attached Files



#10
Xaratas

Xaratas

    (7) Enchanter

  • Members
  • 901 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

That looks strange.

Way 1: http://www.dirks-com...tsverlauf-3.jpg

I don't know how this translates in windows, hope you can find it. The red x link directly to the error message and the windows self help function.

 

Way 2:

If your display driver stops maybe the windows system log has something. In Start -> Run (or Win + R) enter: eventvwr

In the Application log should be some message with regard to the grafic driver



#11
Xaratas

Xaratas

    (7) Enchanter

  • Members
  • 901 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

 

 

@LonelyFatGuy

Your game runs in window mode, try to change the file prefs next to the output log and check/change booth lines which contains fullscreen to 1

    <pref name="FULLSCREEN" type="int">1</pref>
    <pref name="Screenmanager Is Fullscreen mode" type="int">1</pref>

i change this in the output_log?

No, in the file named "prefs". Its in the same folder as the output_log.



#12
Suen

Suen

    (4) Theurgist

  • Members
  • 399 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

Unfortunately for windows the preferences are in the registry.

In Windows 7 they are under HKEY_CURRENT_USER\Software\Obsidian Entertainment\Pillars of Eternity

_currentDisplayMode seems also doing something



#13
Suen

Suen

    (4) Theurgist

  • Members
  • 399 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

Suen,

 

Thanks for your reply. I did have an energy-saving profile active. I have since changed it to high performance but am getting the same result. I'm not sure why it's booting with the Intel® HD Graphics card and not the AMD Mobility Radeon HD 5000.

 

J.

Well, the game should run with just an intel graphic card - got a i5 myself - so it's not that alone.

I thought it could be the switching between the cards, but I can't really say.


Edited by Suen, 27 June 2016 - 05:48 PM.


#14
kwbonin

kwbonin

    (0) Nub

  • Initiates
  • 2 posts

Unfortunately for windows the preferences are in the registry.

In Windows 7 they are under HKEY_CURRENT_USER\Software\Obsidian Entertainment\Pillars of Eternity

_currentDisplayMode seems also doing something

I had the same problem on PC.  I changed the _currentDisplayMode_h1512211402 dword from 2 to 1 and it is working now.  It is back in full screen mode, but working.  Now the question is how do I successfully get this game to run in windowed mode?







Also tagged with one or more of these keywords: blackscreen, wont start, issue

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users