Jump to content
  • 0

Here Comes The Flood frozen in General Store


thefoehammer

Question

Just rolled for the items after closing and Merisiel is stuck with no options. Tried everything that has worked in the past, restarting and continuing, selecting other characters and come back, etc. trying to avoid forfeit as this is my 4th good run on this scenario where a bug is preventing me from advancing.

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...