Jump to content
  • 0

Orik Shield


Dezea

Question

Hello !

 

First of all, thanks for the quality of the game, I've been geeking it for the last week with great enjoyment !

 

Just encountered a problem tho : Waiting for the release of part 4, I'm set on getting all the legendary Items, and after getting the Samisen into the vault, I just finished all of part 1, but...The Orik Shield wasn't added to the vault.

I know you don't get the item right in your inventory after unlocking it, but there I didn't even got the victory screen where you get rewarded with it getting added to the vault, and after a Vault inspection...He wasn't there indeed.

Any help or advice ?

 

Thanks
Dezea

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

This has come up before, and another gent came up with a procedure...  Go to the Scenario Selection screen with the same party with which you completed Burnt Offerings on Legendary.  Tap each Scenario in turn, and watch the Difficulty skull.  It should be Red as you touch all five, since you completed them all on Legendary.  If one is green or blue, redo that scenario on Legendary and see if the Shield is awarded then.

 

Hope this helps.

"I need a lie-down" is the new "I'll be in my bunk..."

Link to comment
Share on other sites

  • 0

Hold on a sec, this was supposed to be fixed with 1.0.3.

 

OP, are you sure you completed all the AD1 scenarios on Legendary?

 

EDIT: Also, looking at the skull icon shouldn't be necessary anymore. I think they fixed the scenario completion indicators (on the scenario selection screen), so you can just look at the checkmarks - if all scenarios have all 3 checkmarks (i.e. 'all difficulties completed') - that should unlock the shield, or otherwise, the unlocking bug persists.

Edited by Longshot11

You can use the 'Mark Solved' button beneath a post that answers your topic or confirms it's not a bug.

The time that devs don't have to spend on the forum is a time they can spend on fixing the game.

Link to comment
Share on other sites

  • 0

Thanks for the answer guys !

 

Sadly, I'm afraid I got the hard-mode problem. All Skull are red, all stars are showed (Well, 3 for each) and yet...No shield : /

 

Here is a picture (Couldn't screenshoot sadly, no  WI-FI for the ipad at work) taken from my phone with all the details. I couldn't show it on the picture, but I double-checked all the skulls to see if they were red. (They were)

 

http://imgur.com/rXTlPmO

 

Is there a way for the dev team to fix it on my save if nothing else works ?

 

Once again, thanks for your help

 

(On another topic : Forgive my english, It's my mother tongues)

Link to comment
Share on other sites

  • 0

Thanks for the answer guys !

 

Sadly, I'm afraid I got the hard-mode problem. All Skull are red, all stars are showed (Well, 3 for each) and yet...No shield : /

 

Here is a picture (Couldn't screenshoot sadly, no  WI-FI for the ipad at work) taken from my phone with all the details. I couldn't show it on the picture, but I double-checked all the skulls to see if they were red. (They were)

 

http://imgur.com/rXTlPmO

 

Is there a way for the dev team to fix it on my save if nothing else works ?

 

Once again, thanks for your help

 

(On another topic : Forgive my english, It's my mother tongues)

Hmm, the only thing I can think of - the fix in patch 103 wasn't retroactive. Did you complete any of these scenarios on Legendary *before* the patch? Did you do it it any *other* party than the one on the screen? If so - you might have activated the bug. Basically, try to replay all scenarios on Legendary with the party that first completed any of the Adventure 1 scenarios on Legendary.

You can use the 'Mark Solved' button beneath a post that answers your topic or confirms it's not a bug.

The time that devs don't have to spend on the forum is a time they can spend on fixing the game.

Link to comment
Share on other sites

  • 0

Well... Sadly, i got the game one week ago,way after 1.3 was here :(

Is there no way to send my save to a dev to get it fixed ? I must confess to be quite a completionist and being locked away from a reward by a bug is kind of a huge deal to me :(

Anyway,thanks for your time and answer, Longshot !

Link to comment
Share on other sites

  • 0

I'm out of ideas. You can try PM one of the devs, but it may take a while, so in the meantime - I'd recommend you try replaying the scenarios on Legendary, maybe one of them just didn't register.

You can use the 'Mark Solved' button beneath a post that answers your topic or confirms it's not a bug.

The time that devs don't have to spend on the forum is a time they can spend on fixing the game.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...