Jump to content
  • 0

Can't get rid of screen tearing.


NoGods-NoMasters

Question

I'm having trouble getting rid of screen tearing on a machine that should easily run Pillars.

 

I have a i5-6300HQ @2.3Ghz (3+ in turbo)

8gb ram Nvidia GeForce GTX 960M w/ 4gb vram

I've tried with vsync on and off. I also capped my frames at 60 to match my monitor. I don't know what else to do. This laptop should be able to run the game without issue.

 

Any suggestions/work-arounds? Thanks.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Hello again,

 

It appears to be a graphical issue. If you haven't done so already, please update both your graphics card as your dxdiag shows your Intel HD Graphics 530 as your primary. Make sure that your Nvidia card is set as your preferred GPU. I have provided a link for you on how to so just in case.

 

https://support.lenovo.com/us/en/documents/ht078706

 

Let me know if that worked. 

Link to comment
Share on other sites

  • 0

Hello again,

 

It appears to be a graphical issue. If you haven't done so already, please update both your graphics card as your dxdiag shows your Intel HD Graphics 530 as your primary. Make sure that your Nvidia card is set as your preferred GPU. I have provided a link for you on how to so just in case.

 

https://support.lenovo.com/us/en/documents/ht078706

 

Let me know if that worked. 

I've got my Nvidia drivers to auto update. They are up to date, and my Nvidia graphics, and not my Intel Graphics are running the game. It still tears, but it isn't game breaking - it's just a minor annoyance. I think I've tried everything; capped my frames, forced vsync, took vsync off, used my Nvidia GeForce experience to optimize settings, etc. 

Link to comment
Share on other sites

  • 0

I have had the same issue since launch. I am also on a laptop with specs that can easily handle the game, and the screen tears when I scroll the map. No graphics issues occur when the map is not being scrolled. 

 

The issue is way worse with VSynch enabled, the higher I set my framerate the less noticeable the tearing becomes even though my monitor is capped at 48. 

I have continually updated my drivers for both the integrated intel chip and my mobile nvidia gpu, and have repeatedly ensured that my nvidia gpu is set to preferred for running Pillars. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...