Jump to content
  • 0

Heritage Hill entering top tower level stuck on load screen


Kalam

Question

Hi all.

 

As the topic says - trying to complete Undying Heritage but whenever I go from tower level 2 to the top level the game gets stuck on the load screen.

 

I left the game for more than an hour in this state and came back to still being stuck on the load screen....

 

I have read about the load / save times but not sure this is the same.

 

I deleted all but my main save and have tried running the game on lower res and in windowed mode etc but still nothing happens.

 

I cannot progress any further in game until I have completed undying heritage so I am a bit bummed now....

 

Any help is welcomed.

 

Thanks

Edited by Kalam
Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Aarik D I did the game cache and it found 4 failed files and so it is downloading them as i type this.

 

will update once the files are done :)

 

UPDATE:

 

Aarik D - verifying the game cache worked :) thank you very much for your help

Edited by Kalam
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...