Jump to content
  • 0

[2.03] The game refuses to start - runtime error



As the topic says I can't run the game - instead of starting I get the runtime error that you can see on screenshot in attachment. This is a fresh install - had removed previous installation of the game, downloaded the latest installers and run them. Some week before I did run the previous installer without errors and I didn't really mess with anything that should affect this.

Version is GoG standalone (as in I'm not using Galaxy). OS is Windows 7 64 bit.




Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

First, sorry for duplicating the topic. It should be noted that the game works fine if you never install Galaxy client. There seems to be a bug in Galaxy's uninstaller that does not remove all of its libraries and as a result, the game tries to load them. This caused the crash as my libraries were rather old (July 2015).


The alternative solution (for those who do NOT have Galaxy installed) is to explicitly delete directory C:\ProgramData\GOG.com\Galaxy.

  • Like 3
Link to comment
Share on other sites

  • 0

And you ran the game and went on long adventures before?

It's odd how the DxDiag.txt says the machine is using the integrated HD Graphics 4600 but the output_log.txt from the game detects a NVIDIA GeForce GT 740M.

This poster had the same issue - http://forums.obsidian.net/topic/82527-error-on-start/


All GOG versions. A suggestion in that thread was "I simply tried to run it out of the GOG Galaxy launcher and it loaded right up. It took a while to import it into GOG Galaxy, so maybe it was applying some sort of patch, but problem solved."

Edited by Sylvus_Moonbow
Link to comment
Share on other sites

  • 0

Yep the game was pretty far in. I only did a clean reinstall because something with GoG 2.02 patcher was borked and not when I loaded a savegame in 2.02 not everything rendered, so I decided to do a clean reinstall.


As for HD Graphics 4600 vs NVIDIA GeForce GT 740M thing - the laptop I'm using has both. DxDiag only shows the integrated one for some reason but the system is set up so that it uses GeForce for everything.


Regarding the suggestion from the other thread... I'd rather see a proper fix than resort to that. I mean I'll use that if no other solution appears but I'd prefer not to have to run Galaxy. Tried it once, didn't like it at all :/

Link to comment
Share on other sites

  • 0

After a clean installation I get immediate crash with CRT runtime error. The cause is an unhandled exception with following callstack:

00 00eded48 71a1872d e06d7363 00000001 00000003 KERNELBASE!RaiseException+0x48
01 00eded80 5a50f287 00eded90 5a9f831c 5a9581b8 msvcr100!_CxxThrowException+0x48
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for GalaxyCSharpGlue.dll -
WARNING: Frame IP not in any known module. Following frames may be wrong.
02 00edee44 5b4239d2 06aedb20 06a11568 00000000 0x5a50f287
03 00edee58 5b425a5d 06aedb20 06a11568 0ffd1c78 GalaxyCSharpGlue!CSharp_IFriends_GetPersonaName+0x1785
04 00edee78 0419b0b0 06aedb20 06a11568 0c79ae30 GalaxyCSharpGlue!CSharp_IFriends_GetPersonaName+0x3810
05 00edeeb8 0419ae0c 0ffd46c8 0ffd1c78 00edeecc 0x419b0b0
06 00edeed8 0419a7d8 0ffd46c8 0ffd1c78 00edef38 0x419ae0c
07 00edef38 0413f541 02ed23f0 00000000 00edef68 0x419a7d8
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for mono.dll -
08 00edef80 100f0566 02ed23f0 00edf0cc 00edf04c 0x413f541
09 00edefb0 1005d7fa 0c4c5e30 02ed23f0 00edf0cc mono!mono_set_defaults+0x22cb
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for PillarsOfEternity.exe -
0a 00edefd4 002b531e 0c4c5e30 02ed23f0 00edf0cc mono!mono_runtime_invoke+0x51
0b 00edefec 00354e09 0c4c5e30 0985fd01 02ed23f0 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x28fbe
0c 00edf02c 0035503e 00edf04c 00000000 00edf050 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0xc8aa9
0d 00edf03c 003550dc 00edf04c 02ed23f0 00000000 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0xc8cde
0e 00edf050 002a5452 108d64bc 00a2757c 0c4c5e30 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0xc8d7c
0f 00edf124 002a5649 0c4c5e30 0985fd01 108d64bc PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x190f2
10 00edf140 002a8102 02ed23f0 108d64bc 0028ceae PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x192e9
11 00edf158 002a7c21 00000004 00000004 00000003 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x1bda2
12 00edf178 0036bef7 00000004 00000007 00edf1e4 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x1b8c1
13 00edf1a8 0036c10e 02df0774 ffffd8b8 00000004 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0xdfb97
14 00edf1cc 0028e99f 00000004 038a15b0 108d3360 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0xdfdae
15 00edf298 0028f636 ffffd8b8 0c6e2e58 626f6c47 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x263f
16 00edf2dc 0040aafd 0bd5b3b8 00edf328 04159df8 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x32d6
17 00edf2e8 04159df8 038a15b0 03895968 0c6e2e58 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x17e79d
18 00edf328 04159d7c 038a15b0 038b8d20 00edf33c 0x4159df8
19 00edf348 04155ef2 038a15b0 0388a4b0 00edf378 0x4159d7c
1a 00edf378 04154387 1006056f 00edf6a4 00edf3c8 0x4155ef2
1b 00edf388 0413f541 03895968 101108f2 03820000 0x4154387
1c 00edf3c8 100f0566 03895968 00edf5d0 00edf6a4 0x413f541
1d 00edf3f8 1005d7fa 0c4895d8 03895968 00edf5d0 mono!mono_set_defaults+0x22cb
1e 00edf41c 002b531e 0c4895d8 03895968 00edf5d0 mono!mono_runtime_invoke+0x51
1f 00edf434 00354e09 0c4895d8 0985fd01 03895968 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x28fbe
20 00edf474 0035503e 00edf6a4 00000000 00edf668 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0xc8aa9
21 00edf484 002a6958 00edf6a4 03895968 00000000 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0xc8cde
22 00edf668 002a6ccb 0c4895d8 0985fd01 00000000 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x1a5f8
23 00edf6a8 002a7070 0c4895d8 0985fd01 00000000 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x1a96b
24 00edf6c8 0028de1e 0d130e50 00000000 e079ee88 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x1ad10
25 00edf734 0031f9f0 00000004 00000000 00000000 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x1abe
26 00edf824 0039bc9b 00000000 00000001 00000000 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x93690
27 00edf860 0039d785 00644ca3 00000000 fe956000 PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x10f93b
28 00edf978 0060fd78 001a0000 00000000 01003d9d PillarsOfEternity!Behaviour::Transfer<StreamedBinaryWrite<0> >+0x111425
29 00edf990 00644c50 001a0000 00000000 01003d9d PillarsOfEternity!Behaviour::Transfer<RemapPPtrTransfer>+0xb3158
2a 00edfa20 75fe7c04 fe956000 75fe7be0 46f3bc8f PillarsOfEternity!Behaviour::Transfer<RemapPPtrTransfer>+0xe8030
2b 00edfa34 77dcad1f fe956000 4719d9cf 00000000 kernel32!BaseThreadInitThunk+0x24
2c 00edfa7c 77dcacea ffffffff 77db023b 00000000 ntdll_77d70000!__RtlUserThreadStart+0x2f
2d 00edfa8c 00000000 00644ca3 fe956000 00000000 ntdll_77d70000!_RtlUserThreadStart+0x1b

It is certainly C++ exception but I was unable to retrieve its name because it occured in GalaxyPeer.dll which has been already unloaded. However, I found out I had Galaxy uninstalled but old GalaxyPeer.dll remained in ProgramData directory from which it was loaded.


So, the solution was to install/update GOG Galaxy again (and perhaps uninstall it later).

Link to comment
Share on other sites

  • 0

I understand your reasons. The less apps running on a PC, the better for memory management BUT at this point, it seems that any other players experiencing the same issue, have resolved it by running it through Galaxy.

As a user of GOG myself, I would be very disappointed to learn that any or all previous GOG games, as well as future purchases, are to be run through Galaxy to work, or some other wrapper function they tend to like adding.

Link to comment
Share on other sites

  • 0

The alternative solution (for those who do NOT have Galaxy installed) is to explicitly delete directory C:\ProgramData\GOG.com\Galaxy.

Well I'll be damned, this worked. I deleted that folder that must've been holdover from the one time I tried Galaxy and game starts again. Thanks man.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...