Jump to content
  • 0

Patch 2.0 GoG won't install


Nobear

Question

I'm running Mac OS X 10.10.5. I previously had the latest GoG hotfix to 1.0.6 installed. I just downloaded the 2.0 patch from GoG's website, ran the installer, and got this message: This patch will not work with your game version!

 

The funny thing is, I checked my game version using Get Info, and it listed the same version as I'd expect to have if the patch worked: 2.7.0.15 (2.0). Then I launched it, and found it was still 1.0.6.whatever. I even loaded a game and looked for some 2.0 features. Perception was still granting Deflection, and I saw no sign of 2.0 features.

 

So... what gives?

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

I just downloaded the base game 2.0 from GoG, moved my old game to the trash (didn't empty it yet), moved the new game to the folder where the old one used to be, and tried opening it three times. Now it shows a progress bar with the system security icon that says "Verifying," and nothing happens after this bar is complete. 

 

Could it be that the system requirements changed, and my MacBook Pro (Retina, 13-inch, Mid 2014) with Intel Iris graphics is no longer supported?

 

Could it be that I need to empty the trash (which I wanted to postpone until I verified that the new game works), or perhaps rename the old game that's in the trash?

 

Could it be because some part of the game expects it to be at the root level of the Applications folder, rather than in a subfolder called Games?

Edited by Nobear
Link to comment
Share on other sites

  • 0

Its possible that there could be some corrupted files while you were installing the game. Simply removing the old folder and placing the new folder will probably not work. Try removing the game completely and the folders and do a fresh install. Its okay to leave those files in the trash bin. Try that and let me know if that worked.

 

Thanks!

Link to comment
Share on other sites

  • 0

Its possible that there could be some corrupted files while you were installing the game. Simply removing the old folder and placing the new folder will probably not work. Try removing the game completely and the folders and do a fresh install. Its okay to leave those files in the trash bin. Try that and let me know if that worked.

 

Thanks!

 

An "install" from GoG is just the game's application file which I can move to any folder on my SSD. Do you mean that I should delete other files that the game uses? If so, which ones?

 

I do want to make sure that my saves are kept if at all possible. I don't mind as much if my preferences are reset.

Link to comment
Share on other sites

  • 0

Here is the link for the game installer for Pillars of Eternity.  Make sure that you delete the folder for Pillars of Eternity and run the installer. Not the patch.  

 

https://www.gog.com/downloader/listing/pillars_of_eternity

 

Let me know if that works.

 

Thanks.

 

I clicked on Mac OS X installer, English, and it gave me the same file as before: a DMG file which, when opened, mounted a disk image containing just the game application and a background window image indicating that I should drag-and-drop into my Applications folder.

Link to comment
Share on other sites

  • 0

Try that and see if it works

 

 

Wow, somehow that linked to a disk image that contained a working game, whereas going through my account page (also from GoG's website) linked to a disk image that contained a slightly different game file that did not work. They looked like they'd be identical. They were advertised as such, by the same company. How can this be most effectively passed on?

 

Anyway, bottom line is, thanks! I fired up the game and saw several new features indicating that it is indeed 2.0. Now, whenever I find the time, I can confidently buy the expansion :p.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...