Jump to content
  • 0

Quest items stuck in "Stash"


PHENICUS

Question

The quest items "Water Skin" and "Engwithan Relief Gem" are stuck in "Stash". I Have tried interacting with the object that requires them with no effect. I Have tried to access in camp, in town square, and after renting room in the inn. 

 

How do I free them/use them. It looks to be a bug and not user error (but anything is possible).

 

Thanks for a great game so far.

 

Blessings

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...